signal out of range -1 reply

Please wait...

gatordh7

Dread thinks I'm a special person

50 XP

12th October 2003

0 Uploads

354 Posts

0 Threads

#1 12 years ago

I just got a new monitor 20" (nothing really great, it's a Metro) and whenever I try to play BF42 it gives me this "signal out of range" message with a black screen in the background (I dont have any probs with my other games, including BF2)

has this ever happened to anyone else before? anyone know why it could be doing this?




Abearikishiswisscheese

Member 35698 thinks I'm a spec

50 XP

27th June 2004

0 Uploads

437 Posts

0 Threads

#2 12 years ago

It sounds like you have bf set to too high of a resolution or (more likely, considering your message) too high of a refresh rate. Both can be set lower via one of the Video.con files (I don't remember which exactly, I'll check for you tommorow, as I also need to check where the audio channels control is for someone else). Obviously, you can also change the settings ingame, but I'm guessing that you'd being blindly clicking (unless the problem is only ingame and the menu does work, in which case I can tell you where to go to fix it.)




gatordh7

Dread thinks I'm a special person

50 XP

12th October 2003

0 Uploads

354 Posts

0 Threads

#3 12 years ago

ya I cant change the settings ingame it's just all black

but ya thanks that would be awsome if you could help me with this, I have no idea i've never seen this error before.

I figured it had something to do with the screen resolution, but I couldnt change it in the settings in-game lol

but hey could I get my old monitor, change the setting from there, then plug in the new one? I'll try that now..




Abearikishiswisscheese

Member 35698 thinks I'm a spec

50 XP

27th June 2004

0 Uploads

437 Posts

0 Threads

#4 12 years ago

Hmm...after thinking about this more, I'm not sure what to think. Let me explain: The BF1942 menu always runs at 800x600, which is a resolution that I should think any 20" monitor can display (or practically any monitor at all). Also, the menu should display at 60hz, the universal standard for any CRT monitor. However, it is possible to override that and force a higher refresh rate. If you have done this, I'm going to have to assume that you know how to change it back or that you at least know what program you used (there are many programs that can do this, so I can't really just guess for you). First things first, if you're just running a universal monitor driver, I strongly reccomend going to Metro's website and downloading their official driver. Now, on the very off chance that your monitor actually does not support 800x600 at 60hz, there is a work-around, though I wouldn't suggest it as a long term solution. It will simply run BF1942 in a window. To do this: 1.Presuming you have BF1942 installed in the standard location (if you don't know, you probably do), follow this path: "C:\Program Files\EA GAMES\Battlefield 1942\Mods\bf1942\Settings" 2.In this folder, you should find a file called "VideoDefault.con". Open it and when Windows asks you with what program you want to open it with, choose notepad. 3.In VideoDefault.con, you should see a line (it should be the first line) that says: "renderer.setFullScreen", followed by a space, and then (if you haven't changed this before) the number 1. To make BF1942 run in a window, simply change this number 1 to the number 0. (To make BF1942 run fullscreen, do the opposite.) 4.Save the edited file and then close it. 5.Before you try running BF1942, see if you can set your desktop resolution to something higher than 800x600. Otherwise, not all of the menu may show. 6.Run BF1942 :) Presuming you have the menu working, one way or another, you'll want to be able to see in-game, aswell (no duh, right?). Well, under video options, just choose a resolution that you are sure will work. (i.e. Check first by trying to change your desktop resolution). If that still doesn't work, it must be due to the refresh rate. Luckily, you can make BF1942 display the possible refresh rates by going back into VideoDefault.con, finding a line that says "renderer.allowAllRefreshRates", followed by a space, followed by the number 0, and changing the number 0 to the number 1, and saving the file. (Note that if you're running BF1942 in a window, changing the refresh rate within BF1942 will have no effect.) Now, in your video options you should be able to choose from different refresh rates, all of which should be supported by your monitor (though, once again, you can check by trying to change your desktop). Of course, once everything is working right, it is reccomended to set the refresh rate as high as possible (as long as you feel that you monitor is displaying it well), as this reducing eye-strain and head-aches caused thereof.




gatordh7

Dread thinks I'm a special person

50 XP

12th October 2003

0 Uploads

354 Posts

0 Threads

#5 12 years ago

wow thanks Abearikishiswisscheese I actually got it to work, now I can start pwning again in FH ;)