Spawnable Kits in BC -1 reply

Please wait...

Nordicvs VIP Member

A Man among humans

50 XP

4th May 2005

0 Uploads

2,865 Posts

0 Threads

#1 13 years ago

[color=black]Hi...[/color] [color=black]Has anyone had trouble getting some kits to spawn through BC, using the fh.lst?[/color] [color=black]Specifically, the mortars?[/color] [color=black]This doesn't show up in BC at all:[/color] [color=black]German_FortificationMortar=StandardMesh(Kit_Mortar_m1)[/color] [color=black]Neither does this:[/color] [color=black]US_FortificationMortar=StandardMesh(Kit_Mortar_m1)[/color] [color=black]Or this:[/color] [color=black]6Jap_SupportMortar=StandardMesh(Kit_Mortar_m1)[/color] [color=black]Et cetera...it's the same for any kit using the (Kit_Mortar_m1) mesh; I tried substituting it with (Mortar_Barrel_M1), but even though it shows up in BC and in the game, it can't be used as a kit it seems.[/color] [color=black](The (Kit_pilot_m1) mesh doesn't work for me either, for any nation, but I've managed to replace them with the nambu kit meshes and they work fine.)[/color] [color=black]Do you have to manually edit these mortars through the con files or are they just quite buggy?[/color] [color=black]Thanks in advance.[/color] [color=black](Oh, BTW, if anyone's interested, I have compiled a list, from a lot of testing most of the kits, which can be used with Battelcraft. There's 27 (of 90 total) usable for the Germans; 24 (out of 61 total) for the Germans--Desert; 25 (out of 73 total) for the Germans--Winter; 28 (out of 88 total) for the US; 28 (out of 30 total) for the USMC; 22 (out of 37 total, including 5 SNLF) for the Japanese; 23 (out of 62 total) for the British; 24 (out of 53 total) for the Soviets; 6 for the Canadians; 16 (out of 38 total) for the French; 16 (out of 38 total) for the Poles; and 6 for the Finns. I didn't do the paratroop versions, since all you have to do is add a 'p' to the kits which can be used for paratroopers.[/color] [color=black]So if anyone wants these for their fh.lst, just let me know and I'll post them.)[/color]




sorry

I'm too cool to Post

50 XP

5th July 2006

0 Uploads

14 Posts

0 Threads

#2 11 years ago

Get me that .lst!




Natty Wallo

FH2 LevelDesigner

50 XP

16th December 2005

0 Uploads

1,652 Posts

0 Threads

#3 11 years ago

use Editor42, most kits show there, or at least its easy to define which weapon you want it to show.. for example a rifle or a mortar.., or a snowman!




Commie

The elusive Member 132837.

50 XP

23rd December 2005

0 Uploads

1,850 Posts

0 Threads

#4 11 years ago

In Ed42 when I place an object from FH it comes up as the grey box with arrow until I save the map and reopen it. Then it shows the object/vehicle/kit. :S




SacredLizard

Its cupnoodles not cuponoodles

50 XP

23rd April 2004

0 Uploads

918 Posts

0 Threads

#5 11 years ago

yeah, that is because when you place an object spawner, it does not load the standardmesh. if you don't feel like reloading your map, you can just use the object placement tool (the yellow box used for placing buildings and other non-pco's) to load the mesh for the vehicle or kit you would like to have. Then you should delete it. Example (for clarity's sake): I want to have four panthers at the German main. I set up the object spawners with the proper vehicle name, and then place them. I place the first one, and then use the Insert key to copy them. Then I click the yellow box, uncheck "objects from template list" and find the panther's name, click on it, and place one. when I put that one panther into the map, all the other ones that I placed before it (as object spawners) appear. I delete the non-object spawner panther, and then position the other panthers to my liking.




Natty Wallo

FH2 LevelDesigner

50 XP

16th December 2005

0 Uploads

1,652 Posts

0 Threads

#6 11 years ago

Yes Ed is a strange boy sometimes...




Guest

I didn't make it!

0 XP

 
#7 11 years ago

Kits always show up as Grey box, reloaded or not for me.... (Consider Reversing Sentence) :lol:




Commie

The elusive Member 132837.

50 XP

23rd December 2005

0 Uploads

1,850 Posts

0 Threads

#8 11 years ago
SacredLizard;3665156yeah, that is because when you place an object spawner, it does not load the standardmesh. if you don't feel like reloading your map, you can just use the object placement tool (the yellow box used for placing buildings and other non-pco's) to load the mesh for the vehicle or kit you would like to have. Then you should delete it. Example (for clarity's sake): I want to have four panthers at the German main. I set up the object spawners with the proper vehicle name, and then place them. I place the first one, and then use the Insert key to copy them. Then I click the yellow box, uncheck "objects from template list" and find the panther's name, click on it, and place one. when I put that one panther into the map, all the other ones that I placed before it (as object spawners) appear. I delete the non-object spawner panther, and then position the other panthers to my liking.

Now that you mention it, I do remember reading about something like that fixing the problem. All good now, I don't have to reload my map everytime I change or add object spawners :D




SacredLizard

Its cupnoodles not cuponoodles

50 XP

23rd April 2004

0 Uploads

918 Posts

0 Threads

#9 11 years ago
RedSand;3666510Kits always show up as Grey box, reloaded or not for me.... (Consider Reversing Sentence) :lol:

well, there may be a few that don't show as a result of random geometries code or other such nonsense, but in general, most of them show the mesh. Perhaps the problem you are having is related to what team you are showing in ed 42? IE: if you spawn an axis only template while viewing allies objectspawntemplates, you will only see a gray box.