Battlefield video problem on Sony -1 reply

Please wait...

maverick_Canada

I'm too cool to Post

50 XP

29th March 2003

0 Uploads

1 Posts

0 Threads

#1 16 years ago

I have just bought battlefield 1942 and am running it on my relatively new Sony PC, which I thought was powerful enough to run this (fast CPU, good graphics etc). But it is slow and during the game the screen changes from color to black and white (sort of negative like). Sometimes it will crash back to the desktop. I am running XP and have DirectX 8.1). I noticed in some of the threads that video cards are the problem, but I would have thought that a new machine like this one would have had enough to run it. Any help would be appreciated.




Sh0rD

¥ Uberhacker ¥

50 XP

10th August 2002

0 Uploads

2,118 Posts

0 Threads

#2 16 years ago

What graphics card do you have? Make sure it supports T & L (it's a must for BF1942).




Mastec

I'm too cool to Post

50 XP

17th August 2003

0 Uploads

4 Posts

0 Threads

#3 15 years ago

I have a Sony PC too and BF1942 will not run on it at all. I even tried a GeForce 4200 getting the same problem, choppy video. I can run MOH, UT, HL, RTCW, ET and Red Faction with all the settings at max. I try to run BF1942 at low settings and still get the crappy choppy video. Sony support could not even figure it out. I just gave up on it completely, figured it will not play BF1942. I know ppl in the clan I retired from that have slower and less powerful computers that can play it just fine.

My setup: 1.5 Ghz 512 M Ram Asylum GeForce FX 5200 400 Mhz f.s.b.

If you ever come up with a solution let us Sony owners know.