Saitek Cyborg 3d gold usb -1 reply

Please wait...

Feldan

I'm too cool to Post

50 XP

22nd March 2004

0 Uploads

1 Posts

0 Threads

#1 15 years ago

Hey all I have an issue that I have been trying to fix and I'm at my wits end with it. I have a Saitek Cyborg joystick and all was fine in all the games till DX9 came out. Then I noticed that the joystick wasn't working correctly. Upon looking in the control panel I noticed that the buttons 1-4 were being constantly engaged, whether I was holding them down or not. I tried contacting Saitek to see if they had a patch or if there was something I could check to see if the joystick was blown but all 10 of my e-mails have been given a deaf ear. Reformatting and going back to DX8 isn't an option since i have HALO and NFS:U that require DX9. I have gone into the cmos turned off legacy usb support, unplugged/plugged it back in, tried doing all the basic crap, etc hehehe. When i do un/plug the joystick back in I noticed in the calibration screen that nothing is wrong an no buttons are pressed but as soon as i touch the controller the buttons start acting up. I have read that DX9 only support 8 position analog controlers on one site and don't know if that is the case. can anyone please help a tortured soul? :micro: Thanks, Feldan




Pestilence64

Battlefield 2 ROX!

50 XP

15th January 2004

0 Uploads

1,126 Posts

0 Threads

#2 15 years ago

had the same joystick for a while, then i installed DX9 and similar crap started happening. i had to buy ine of there newer sticks.