Civilization4/Vista Questions 2 replies

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

Hi. I recently updated Civ IV to the 1.74 patch and found that it would not work on vista home premium 32bit (it displays that D3DX9_32.DLL could not be found and to reinstall). I reinstalled and went with the 1.61 patch and have had no problems. I am wondering if there is any way to get 1.74 to work and how. I am also considering buying the Warlords and Beyond the Sword expansions and I am wondering if those will work on Vista. Any help you can give would be great.




Guest

I didn't make it!

0 XP

 
#2 10 years ago

let me reprhase this now that there seems to be a solution to the 1.74 patch problem, WILL WARLORDS AND BEYOND THE SWORD WORK ON VISTA HOME PREMIUM 32BIT?




Ensign Riles VIP Member

No! I'm Spamacus!

426,516 XP

17th June 2003

0 Uploads

39,479 Posts

1 Threads

#3 10 years ago

Both of the expansions work with Vista Premium 32bit.