I just got my Ghost Recon Advanced Warfighter game and... 1 reply

Please wait...

ghost,recon,noob

I'm too cool to Post

50 XP

4th February 2008

0 Uploads

10 Posts

0 Threads

#1 10 years ago

Hey i just got me my Ghost Recon Advanced Warfighter game and every time i want to join a server it always says "That i cant play on it" becouse my version is grpcrl1.02 and i need my version to be grpcrcl1.35 how can i get it to be 1.35??? how can i get my version to be 1.35




FN_lewrbm69

It's Not Easy Being Green

50 XP

10th November 2003

0 Uploads

3,372 Posts

0 Threads

#2 10 years ago

there is a ghost recon related site the patch is on the front page. here is a direct link to it. Ghost Recon Advanced Warfighter v1.35 Patch, Ghost Recon Advanced Warfighter Downloads, Ghost Recon Advanced Warfighter Patches