Northern Strike and Patch 1.25 Q's 0 replies

Please wait...

BigJediGuy

2nd Lieutenant Silver

50 XP

15th July 2006

0 Uploads

175 Posts

0 Threads

#1 11 years ago

I got Northern Strike but when I try to install it a message box says "This Booster Pack requires version 1.20 or higher". I got version 1.25 of Battlefield 2142. Also I DL v1.25 a few days ago and I get to the main screen I type in my password hit ok. Then I select my guy and hit ok. Then my computer freezes up. I hope somebody here knows what's wrong with Northern Strike and v1.25 patch. HELP!!!