Patch 1.74 MAJOR problem 0 replies

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

When I go to go online it says that I need patch 1.74, I go to download it but, it says download failed and kicks me offline, so then I got the patch 1.74 download off here and I go to to down load it and it says the setup has detected that version 1.09.000 of Sid Meier's Civilisations 4 is already installed This setup is not compatible with this version You will have to uninstall the previous version before installing this version Please Help me!!!