Random CTDs in Fallout 3 18 replies

  • 1
  • 2

Please wait...

AlDaja

SFC III Troubleshooter.

50 XP

5th September 2006

0 Uploads

11,263 Posts

0 Threads

#11 12 years ago

…and here I was going to get the game next month. Don’t want to invest in it if it has crash issues. :(




BlitZ, The 57th

Fack, Fack you, Fack that

50 XP

20th April 2007

0 Uploads

3,236 Posts

0 Threads

#12 12 years ago

Yeah I'm gonna try out what giskarduk did. But other than the crash issues, its a pretty okay game. Especially if you like the some immersion and open-endedness.




AlDaja

SFC III Troubleshooter.

50 XP

5th September 2006

0 Uploads

11,263 Posts

0 Threads

#13 12 years ago

So is it a consistent crash? I know Starfleet Command III used to crash a lot before the patch was fixed. Still does on occasion if you play for too long. I don’t want to have the game crash every 10 minutes or so, otherwise it takes the fun out.




BlitZ, The 57th

Fack, Fack you, Fack that

50 XP

20th April 2007

0 Uploads

3,236 Posts

0 Threads

#14 12 years ago

Well it crashes about 2-3 hours in. Crashes earlier if you have some mod conflicts...

@giskarduk: Do you mean changing settings in your overall sound system? or just the ones that fallout 3 use... Because I'm not seeing a choice to choose which system to play on what mode in Fallout 3.




AlDaja

SFC III Troubleshooter.

50 XP

5th September 2006

0 Uploads

11,263 Posts

0 Threads

#15 12 years ago

All right then, hopefully someone figures out the glitch with a new patch by the time I get the game – thanks!




CyberRaptor

Jinxed

50 XP

5th August 2004

0 Uploads

2,593 Posts

0 Threads

#16 12 years ago

Your specs are really not that great for this game. If you've got texture settings at high and stuff like anti-aliasing enabled, you may be running out of texture memory. I made the mistake of getting the 320 MB version of the 8800 GTS, and often it would crash in games if they consume to much texture memory. It's happened to me in Oblivion and Crysis plenty of times (though I use Qarl's Texture Pack anyway). Another possible cause is overheating. Use something like Coretemp to check the temperatures after playing for awhile. I've had my computer get so hot that it locked up totally and I had to shut it down for a while. It's better now since I blew all the dust out of there, and it might help if you did the same thing. Also, could you please tell us what mods you're using?




Guest

I didn't make it!

0 XP

 
#17 12 years ago

BlitZ, The 57th;4823527Well it crashes about 2-3 hours in. Crashes earlier if you have some mod conflicts...

@giskarduk: Do you mean changing settings in your overall sound system? or just the ones that fallout 3 use... Because I'm not seeing a choice to choose which system to play on what mode in Fallout 3.

Look for it in windows Blitz, not in the game.

I use an Xonar card and it supports the DS3D GX stuff for surround stuff. So I use the Xonar D2 Audio Center on windows to change the settings, which is easy enough to do. It might be a control panel program for you Blitz.

Fallout 3 really dislikes this new surround features everybody seems to be adopting. So its a problem that will get worse as newer hardware supporting it becomes common place.

I found the tip online and it was reported to work on creative cards and a bunch of other surround sound supporting cards as well as mine. Some I have never heard of but some do not call it DS3D GX, some just call it DS3D.

Basically its Direct Sound 3D or something, in game surround sound features. Clicking PCM stereo in your sound confuration program might be all you need to do to turn it off on your system.

DS3D works great for most games, its just fallout 3 that hates it.




BlitZ, The 57th

Fack, Fack you, Fack that

50 XP

20th April 2007

0 Uploads

3,236 Posts

0 Threads

#18 12 years ago

CyberRaptor;4823932Your specs are really not that great for this game. If you've got texture settings at high and stuff like anti-aliasing enabled, you may be running out of texture memory. I made the mistake of getting the 320 MB version of the 8800 GTS, and often it would crash in games if they consume to much texture memory. It's happened to me in Oblivion and Crysis plenty of times (though I use Qarl's Texture Pack anyway). Another possible cause is overheating. Use something like Coretemp to check the temperatures after playing for awhile. I've had my computer get so hot that it locked up totally and I had to shut it down for a while. It's better now since I blew all the dust out of there, and it might help if you did the same thing. Also, could you please tell us what mods you're using?[/quote]

Yeah I get the idea my specs aren't that awesome for Fallout 3, I have textures set to low and Antistrophy thing set at 4 samples and Anti Aliasing set to 2 samples.

I only use texture packs specifically for weapons and certain clutter. My computer doesn't heat up ever I noticed. (as in touching the side or back doesn't result in a warm feeling) It only does that fan sound when it really starts using alot of memory or RAM; like when I have multiple firefox web-pages up and playing a game.

As for my mods, the list is quite long.... I can PM the list to you, but I'm afraid it might be a hassle for you and all :uhm:

[quote=giskarduk;4824302]Look for it in windows Blitz, not in the game.

I use an Xonar card and it supports the DS3D GX stuff for surround stuff. So I use the Xonar D2 Audio Center on windows to change the settings, which is easy enough to do. It might be a control panel program for you Blitz.

Fallout 3 really dislikes this new surround features everybody seems to be adopting. So its a problem that will get worse as newer hardware supporting it becomes common place.

I found the tip online and it was reported to work on creative cards and a bunch of other surround sound supporting cards as well as mine. Some I have never heard of but some do not call it DS3D GX, some just call it DS3D.

Basically its Direct Sound 3D or something, in game surround sound features. Clicking PCM stereo in your sound confuration program might be all you need to do to turn it off on your system.

DS3D works great for most games, its just fallout 3 that hates it.

Thanks, I'll try it out. I've heard how tinkering with Fallout.ini in the audio section may cause crashes too, since fallout 3 is sensitive to audio configurations.




Guest

I didn't make it!

0 XP

 
#19 12 years ago

Blitz

Yes its probably related, Fallout 3 does use surround but it becomes unstable when you use it.




  • 1
  • 2