Unable to setup D3D fatal error msg 3 replies

Please wait...

Guest

I didn't make it!

0 XP

 
#1 13 years ago

:confused: Hello, I am new to this forum/board. I loaded my 10 year old son's new History Channel: The Alamo game and everything appeared to be fine. When he went to play it, however, this message came up: Fatal Error: Unable to setup D3D'. I ran the DirectX diagnostic tool on his pc (which, by the way, does not have internet connectivity) and it came back with no problems found, all tests successful. But it did say Direct 3D functionality not available. His pc has the following stuff: Win 98 operating system SiS530v.drv version 4.12.0001.1081 I have no idea what is wrong...I am sure there are many out there who can just look at this and tell me what it is. I am not a techie... :) Thanks so much mom2chris




RadioactiveLobster Forum Admin

Jeff is a mean boss

564,279 XP

28th July 2002

0 Uploads

53,056 Posts

1,322 Threads

#2 13 years ago

first of all, we here at Gaming Forums do not believe in "Educational" games nor games related to learning of ANY kind.....j/k....

Do u know what version of DX u have, and what video ur using, what card or onboard?


If there is no image, Mikey broke something...



ScOrPY VIP Member

Advanced Member

50 XP

17th November 2003

0 Uploads

15,582 Posts

0 Threads

#3 13 years ago

It seems that you have a SiS inbuilt card from what I can see but in dxdiag tool go to Display and tell us fully what it is. I'd assume you would need the latest motherboard/chipset drivers and the onboard VGA drivers. If you know your motherboard model I can point you to drivers you would need.




RadioactiveLobster Forum Admin

Jeff is a mean boss

564,279 XP

28th July 2002

0 Uploads

53,056 Posts

1,322 Threads

#4 13 years ago

after a quick google search....and translating the page from French...i have found that, accoridng to ur driver version....u prob have something running on the SIS 530 chipset, with a 530 Rev A2 chip type...

according to this the date of the driver is 7/8/2000...so its pretty old....


If there is no image, Mikey broke something...