help, what have i done wrong -1 reply

Please wait...

JANUS_2704

I don't spend enough time here

50 XP

2nd March 2004

0 Uploads

37 Posts

0 Threads

#1 16 years ago

Hi, i am a rookie when it comes to installing ships into Armarda 2. I know how to do it, and i can get a ship in the game, (without the build icon, but who cares, i am a beginner!). I know how to do it manually without extracting, so i am trying to get the Excelsior B class ship into my game. I have modified the odf and the tech trees, so i can see and am able to build it in instant action, and i actually see it being built in the shipyard, but as soon as it finishes, and proceeds to come out, the game crashes, saying ''armarda2.exe has performed an illegal operation.

PLEASE I NEED HELP, what have i done wrong.

I have attached my files with the excelsior b, could anyone install it and take a look at what happens and see if it crashes and possibly figure out why?

I would be very greatful

Thanks

James

PS i donot claim to have made the excelsior b all rights and acknowledgements go to DAWN (http://www.armada2files.com/file.info?ID=5029)




Porty

Warrior Ant

50 XP

21st August 2002

0 Uploads

505 Posts

0 Threads

#2 16 years ago
JANUS_2704I have attached my files with the excelsior b, could anyone install it and take a look at what happens and see if it crashes and possibly figure out why?

I haven't installed it but after a quick look I may have seen your problem. Does the following weapon exist in your C:\Program Files\Activision\Star Trek Armada II\odf\weapons\Phasers folder???

// Phaser weapon1 = "fptype9" weaponHardpoints1 = "hp12" "hp13" "hp14" "hp15" "hp16" "hp17"

If not, that could well be the problem. I know I don't have it in mine!! ;)




JANUS_2704

I don't spend enough time here

50 XP

2nd March 2004

0 Uploads

37 Posts

0 Threads

#3 16 years ago

thanks, i will try and set the phaser to the std one.

Also if u want to install the ship you will need this file too? (i forgot it in the zip!)

fyard2.odf

Thanks

James




mad_designer

mad designer

50 XP

25th January 2004

0 Uploads

83 Posts

0 Threads

#4 16 years ago

The problem could also be with weapon 2, fphot8, but I'm not sure, since I can't check the odf files right now.




JANUS_2704

I don't spend enough time here

50 XP

2nd March 2004

0 Uploads

37 Posts

0 Threads

#5 16 years ago

thanks for the help guys, i tried to fix the problem. I changed all the weapons to std ones, and i put in the wireframes into the spr file, but it still crashes? could you please take a look at my odf's/spr and try and figure out what is wrong?

Thanks

James




Haryous

The Internet ends at GF

50 XP

20th November 2003

0 Uploads

118 Posts

0 Threads

#6 16 years ago

right, i will tell you what i did to get it into my game, i had tonnes of trouble with the one that came in both Borg Incursions, they have differnet weapons so unless you find all the reative weapon files then it wont work, (and it still doesnt work even with the files in the folders) so what i did was i went here http://www.armadafleetcommand.com/afc/modules.php?name=Downloads&d_op=viewdownloaddetails&lid=1472&ttitle=Ship_Pack_Ares,_Excalibur,_and_Excelsior-B#dldetails download this, ITS FOR A1, but i used Armod II to put in all the missing fields, when i ran the game, low and behold, it worked!. thats what i suggest you do, however if you have problems i can send you my odf and then it should work ok? :cheers:




JANUS_2704

I don't spend enough time here

50 XP

2nd March 2004

0 Uploads

37 Posts

0 Threads

#7 16 years ago

thanks Haryous, i will try it in the morning, cheers , i will let you know how it goes




JANUS_2704

I don't spend enough time here

50 XP

2nd March 2004

0 Uploads

37 Posts

0 Threads

#8 16 years ago

Cool, thanks for the help guys, i fixed the problem, the ship can be created now, and the game doesn't crash, i redid the weapons in the odf to std ones, and that seems to have done it, i added the wireframe sprite lines to the global spr.

But now i have another problem.......:@

The ship WILL NOT MOVE!

How do i fix this

Thanks

James




JANUS_2704

I don't spend enough time here

50 XP

2nd March 2004

0 Uploads

37 Posts

0 Threads

#9 16 years ago

Cool, i fixed the problem with the excelsior not moving, i changed the included odf in the fexcelb odf to a std, like crusie3 or fcruise3 and it worked, it now moves,...

now all i need to do is learn how to make button icons, any help would be appreciated

Thanks

for your help




Porty

Warrior Ant

50 XP

21st August 2002

0 Uploads

505 Posts

0 Threads

#10 16 years ago
JANUS_2704now all i need to do is learn how to make button icons, any help would be appreciated

There is a full button tutorial in Westworlds Big Book of Modding!! :)