Hyperdrive -1 reply

Please wait...

mad_designer

mad designer

50 XP

25th January 2004

0 Uploads

83 Posts

0 Threads

#1 16 years ago

Since I created the Prometheus Class (BC-303), I decided to create the hyperdrive for it. But when I go to use it, the game crashes. I created it by copying all the files for Concept futures slipstream drive and renaming it. Can any one tell me what would cause it to crash. All I added to the names of the files was hyperdrive, nothing else(replacing slipstream). It crashes after I choose my destination. As far as I know, every thing is typed in correctly. I want to get this to work because my next model (No textures, ODF, wireframes, or buttons) will be an Asgard Mother ship (assuming that I can find some good pictures of it), then possibly the F-302 and a Hatak class Go'uld Mothership, all of which use hyperdrive engines.




captain_stan

Armoured Ships Rule!!!

50 XP

16th January 2004

0 Uploads

68 Posts

0 Threads

#2 16 years ago

i dunno bout the weapon but stargate ships will be a cool mod




S618-18741

Captin Prozack

50 XP

18th January 2004

0 Uploads

191 Posts

0 Threads

#3 16 years ago

If u want you could send me the odf files an ill take a look at them an then send them back and ill tell u if i can spot anything wrong. My E-mail address is [email="chrislake740@hotmail.com"]chrislake740@hotmail.com[/email] . other than that i cant think of anything as long as you didnt change the file names, if u did you have to change the lines of code that link the file. S618-18741 P.S. Stargate rocks hope you get this working




mad_designer

mad designer

50 XP

25th January 2004

0 Uploads

83 Posts

0 Threads

#4 16 years ago

Actually, I did change the file names. I renamed everything to correspond to the new names. I changed the ODF, SOD, TGA, and added it to the tech and spirit files. I've never had any problems before, just yesterday I made copies of the kingon poleron torpedoe, borg regeneration, and the romulans phase cloak and cloak enhancer. And they all work perfectly with the balance of power class I created. Before I uninstalled then reinstalled armada 2, I could even research them at a new research facility I created from a copy of the fed research facility and the Balance of Power class was created at a new ship yard made from a copy of the advanced shipyard. Thats the reason that I couldn't figure out why it won't work, since I've copyed other special weapons and got them to work perfectly. If you want, I can send you the original slipstream odf, sod, and tga files so you can try and figure it out. The reason I changed the names is that I still want the other ships to use the original slipstream drive. If you do want me to send the files, I'll still try and figure it out on my own so that I don't seem to just have other people do the work for me. Thanks for any help you can give me.




Twitch1

The Borg will rock your world!

50 XP

4th December 2003

0 Uploads

319 Posts

0 Threads

#5 16 years ago

Are you sure you changed the name inside the special weapons files? Example-Like the class label transwarpdrive should be there and the name of the ODF needs to be the same as what is mentioned as in:

//Name of the ODF file for the ordinance for this weapon ordName = "twarpd"

//Display name for this weapon wpnName = "Transwarp Drive"

In other words if you have no twarpd.odf the weapon won't work. Don't change the class label from transwarpdrive to hyperdrive or slipstream in the ordnance file or it will not work.




mad_designer

mad designer

50 XP

25th January 2004

0 Uploads

83 Posts

0 Threads

#6 16 years ago

Yes, I did change that name. The original was slipstreamdrvo, I changed it to hyperdrivedrvo. I'm going to try it again, I reinstalled a2 so it was deleted. I think part of the problem is the file names. On all the others, the name of the file starts with a "g" (ex. gpoleron=kingon poleron torpedo) and all I did to the files was replace the "g" with an "f". But with the Hyperdrive files I completely change the name, so I'm going to try it like this, and if it still don't work, then I'm Clueless. If you post a reply Please note that it will take me a while to respond, we just had DSL installed so now only my parents computer is connected to the internet, and I'm almost positive that that computer is full of viruses. So unless you want to catch one, I won't be sending any thing from my house, only from my high school.




S618-18741

Captin Prozack

50 XP

18th January 2004

0 Uploads

191 Posts

0 Threads

#7 16 years ago

Thats what i was wondering, I did have the same probblem when making my real transwarp mod i found out later that ive just got some of my files confused, make sure that the contents of

Slipstream.odf is the same as Hyperdrave.odf (or whatever you called it) Slipstreamdrvo.odf is the same as hyperdrivedrvo Slipconduit.odf is the same as your verssion e.g. Hdrvconduit.odf try that other than that i dont know id have to have a look




mad_designer

mad designer

50 XP

25th January 2004

0 Uploads

83 Posts

0 Threads

#8 16 years ago

Thanks, it works perfectly. Although I ran into another problem. I'm trying to pre-create the hyperdrive for the F-302 so that it will only go so far per jump into hyperspace, since in SG-1, the naquadria is unstable and can't be used for an extended period. Setting the distance restriction I already did, the problem is that if you set your destination to far away that the ship will warp towards the destination untill it is in range to use the hyperdrive. Do you know of any way to make it so that its like trying to open a transwarp portal in an area you haven't ben to yet, meaning it won't even let you enter in the destination unless it in range? I doubt it's possible, but any help would be appreciated, because I want to make it as canon as possibe.




Twitch1

The Borg will rock your world!

50 XP

4th December 2003

0 Uploads

319 Posts

0 Threads

#9 16 years ago

Mad- I haven't delved into that and do not know. Definitely tell your folks to get Norton and a year's subscription for Norton. It updates frequently with new stuff to combat viruses. They may have to clean up certain viruses before Norton will even work as there are some that thwart anti-virus program from being installed.




mad_designer

mad designer

50 XP

25th January 2004

0 Uploads

83 Posts

0 Threads

#10 16 years ago

Thanks for the advice, I'm trying to convince them to get anti-virus and firewall software. In order for my computer to use the DSL connection, I'll have to connect all the computers to a router, then to the modem. So it highly likely that if my parents computer has a virus, that it will spread to my computer since they'll be connected by a network. Also, do you know anyone who would be interested in transforming my prometheus model for armada 2? I can't start on the other models untill I get the prometheus done. I can provide pictures of the original that they can use as a reference for the texture. Any help would be appreciated.