Foundation Sound Problem 3 replies

Please wait...

Zeus9518

STBC Rocks

50 XP

23rd December 2002

0 Uploads

166 Posts

0 Threads

#1 15 years ago

Hi all,

I have upgraded the Sovereign's weapons, but I have encountered a problem with the Foundation sound system. Although all the relevant sound files are in the correct place and correctly detailed in the Sovereign's py file, not all the weapons sound when fired. Can anyone tell me if there is an upgraded version of the Foundation, with this problem sorted, other than that on the BCFiles website? I have tried the following website, which I obtained from the Foundation Readme, but I can't seem to access it. Can anyone help?

www.beldar.com/~dasher/Foundation-current.zip, which is on the Foundation




Blackrook32 Game Admin

BCFiles Site Administrator

4,741 XP

5th April 2002

56 Uploads

444 Posts

1 Threads

#2 15 years ago

Originally posted by Zeus9518 Hi all, I have upgraded the Sovereign's weapons, but I have encountered a problem with the Foundation sound system. Although all the relevant sound files are in the correct place and correctly detailed in the Sovereign's py file, not all the weapons sound when fired. Can anyone tell me if there is an upgraded version of the Foundation, with this problem sorted, other than that on the BCFiles website? I have tried the following website, which I obtained from the Foundation Readme, but I can't seem to access it. Can anyone help? www.beldar.com/~dasher/Foundation-current.zip, which is on the Foundation

Check your scripts/tactical/projectiles folder to see if all of the weapons your using for your Sovereign mod is installed. As for Foundation, I use Foundation20020530b. I'm aware that Dasher42 has made "newer" versions of his mod. But like the old saying goes-

"If it ain't broke don't fix it."


"Fortune favors the Bold..."



Zeus9518

STBC Rocks

50 XP

23rd December 2002

0 Uploads

166 Posts

0 Threads

#3 15 years ago

Thanks BlackRook32 for the prompt reply, it's greatly appreciated. I have checked as you suggested and all must be well, because all the sounds work perfectly when the Foundation is not installed. As soon as I do, less than half of the weapon sounds are heard. Any further ideas would be greatly appreciated.




Blackrook32 Game Admin

BCFiles Site Administrator

4,741 XP

5th April 2002

56 Uploads

444 Posts

1 Threads

#4 15 years ago
Originally posted by Zeus9518 Thanks BlackRook32 for the prompt reply, it's greatly appreciated. I have checked as you suggested and all must be well, because all the sounds work perfectly when the Foundation is not installed. As soon as I do, less than half of the weapon sounds are heard. Any further ideas would be greatly appreciated.

You can use BCMI to make a "Plugin" file for the SFX. The Plugins folder should be in your BC directory ex: Bridge Commander/scripts/plugins. I had to do this last year because I couldn't hear the pulse phasers SFX from the Defiant mod. I also "don't" have the BC1.1 patch applied in my install of the game. I don't know if playing with "BC1.0" makes a difference.

But it's worth a shot.


"Fortune favors the Bold..."