Half-Life 1 CD Check? -1 reply

Please wait...

The Typer

Formerly justincase3

50 XP

20th June 2006

0 Uploads

1,120 Posts

0 Threads

#1 12 years ago

If you installed Half-Life 1 Game of the Year Edition onto your computer, would it also be installed into Steam so there is no CD Check or will you need a CD?




pvt. Allen

I would die without GF

50 XP

20th July 2005

0 Uploads

5,654 Posts

0 Threads

#2 12 years ago

You should open Steam and then on hte 'Store' page choose option 'Activate product on Steam...' from the bottom. There type in the GOTY edition CD key and you should get all the games from this edition on Steam. You can also run normal Half-Life without CD, it was Blue Shift expansion wich first required it to play.




The Typer

Formerly justincase3

50 XP

20th June 2006

0 Uploads

1,120 Posts

0 Threads

#3 12 years ago

I mean if you borrowed the CD and installed it onto your computer. Would you need to put the CD onto your computer every time you played it or what?




pvt. Allen

I would die without GF

50 XP

20th July 2005

0 Uploads

5,654 Posts

0 Threads

#4 12 years ago

If this is a borrowed CD you can't use the key on Steam since it's probably already used. As for the Half-Life basic edition, you can play it without the CD, ofcourse in case of multiplayer again, the key might be in use.




The Typer

Formerly justincase3

50 XP

20th June 2006

0 Uploads

1,120 Posts

0 Threads

#5 12 years ago
pvt. AllenIf this is a borrowed CD you can't use the key on Steam since it's probably already used. As for the Half-Life basic edition, you can play it without the CD, ofcourse in case of multiplayer again, the key might be in use.

But not GOTY edition?




pvt. Allen

I would die without GF

50 XP

20th July 2005

0 Uploads

5,654 Posts

0 Threads

#6 12 years ago

I think that any version of Half-Life normally installed on the pc (means not key usedi n Steam to download it) will run without CD. Unless my from Half-Life - Generations edition runs fine alone. I'm not sure if you don't have to install newest patch for that though.