New map lag -1 reply

Please wait...

Drossvirex

I'm too cool to Post

50 XP

5th April 2004

0 Uploads

3 Posts

0 Threads

#1 15 years ago

Is it normal for a bare map to be really laggy? I'm new to battlecraft.. I have an amd 2600+, radeon 9700 and 1gb of ram I don't have any problem with the game itself, it's just when I test a map i've made and i mean the default terrain generated map, it's very laggy. I press forward and he goes forward for a long time...it's like it's trying to keep up and I don't understand because the fps is fine. This sucks, I want to make a map..




nuttydave

Grrr woof woof Grrrr

50 XP

15th November 2002

0 Uploads

117 Posts

0 Threads

#2 15 years ago

dont run stuff in the background and when you test a map check the settings remeber your running a map and playing it




Drossvirex

I'm too cool to Post

50 XP

5th April 2004

0 Uploads

3 Posts

0 Threads

#3 15 years ago
nuttydavedont run stuff in the background and when you test a map check the settings remeber your running a map and playing it

What do you mean? I don't have anything running. I made sure there were no open processes in Windows XP and it still does this. I can run the regular game with all kinds of stuff open no problem anyway. I don't get it because this map is barren while the ones in the game have all sorts of models and AI.




Drossvirex

I'm too cool to Post

50 XP

5th April 2004

0 Uploads

3 Posts

0 Threads

#4 15 years ago

Well I guess it's because I have the map editor open at the same time as the game. Why does the map editor have the option to 'test' the map if doesn't really work? How do I launch my maps in the game?




greenbudsmapediting

The Internet ends at GF

50 XP

9th December 2003

0 Uploads

119 Posts

0 Threads

#5 15 years ago

if your using battlecraft just exit BC and start the game and choose your map...




kroy

I'll Be Back !!!

50 XP

10th January 2004

0 Uploads

33 Posts

0 Threads

#6 15 years ago
DrossvirexIs it normal for a bare map to be really laggy? I'm new to battlecraft.. I have an amd 2600+, radeon 9700 and 1gb of ram I don't have any problem with the game itself, it's just when I test a map i've made and i mean the default terrain generated map, it's very laggy. I press forward and he goes forward for a long time...it's like it's trying to keep up and I don't understand because the fps is fine. This sucks, I want to make a map..

Im having the same problem, I can play Bfv just fine with no lagg but when i load my map to check out the object placements its laggy has hell....???? here is my system configuration: AMD Athlon xp 3200+ 400 mghz fsb, Video Card:Radeon 9800xt 256mb, Motherbourd:Abit kv7 kt600 via chipset, Sound Card: Creative Sound Blaster Audigy 2zs, Power supply:Antec True 480 watts Hard Drives:2 Western Digital 80 gig 8mb cach 7200rpms, Windows xp pro Memory:2 sticks 512mb Giel pc 3200 466 mghz... If anybody has any clue has to why my custom map is so damm laggy please contact me on msn messenger:kroy88@hotmail.com P.S. Im having trouble with the under growth and over growth, on increasing the density on the under and over growthes any i dea's ??




Guest

I didn't make it!

0 XP

 
#7 15 years ago

If you use "NO" custom Textures in your Map try this :

in Battlecraft-Vietnam you go to ARCHIV FILE EDITOR (MENU->Tools)

and then you open the bfvietnam/Levels/"your mapname"/init.con ....

...and delete the line ->> textureManager.alternativePath Texture

That's it !! Your Map need's less time to load and will not be laggy !




DoomSayer

GF Pwns Me!

50 XP

13th June 2004

0 Uploads

45 Posts

0 Threads

#8 15 years ago

[color=mediumturquoise]Go into your maps init.con file and add a[/color] [color=red]REM[/color][color=white] [color=mediumturquoise]to this[/color] [/color][color=mediumturquoise]statement[/color]: rem ********************************************* rem Created by Battlecraft Vietnam. Copyright (c)2003,2004 Digital Illusions CE rem ********************************************* Game.setLoadMusicFilename "music/music4" rem game.setLoadingLeftText "LOADING_HOCHIMINHTRAIL_LEFT_TEXT" rem game.setLoadingLeftTitle "LOADING_HOCHIMINHTRAIL_LEFT_TITLE" rem game.setLoadingRightText "LOADING_HOCHIMINHTRAIL_RIGHT_TEXT" rem game.setLoadingRightTitle "LOADING_HOCHIMINHTRAIL_RIGHT_TITLE" rem game.setLoadingLeftPosition 50/20 rem game.setLoadingRightPosition 550/300 [color=red]rem[/color] [color=mediumturquoise]textureManager.alternativePath Texture[/color] renderer.diffuseColor 0.894118/0.894118/0.894118 renderer.SecondaryDiffuseColor 0.447059/0.419608/0.400000 renderer.MLambientColor 0.25 renderer.ambientColor 0.149020/0.149020/0.149020 renderer.specularColor 0.400000/0.400000/0.400000 This stops the textures from double loading and should free up some if not all your lag.