HL2 killed my vid card -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 15 years ago

I have a Radeon 9800 Pro 128MB by PowerColor. There is no overclocking on the card. I have played a wide variety of games and never had any cooling issues. Now HL2 comes around and looks amazing. I played CS: Source for many hours with no problems. Then it started. What looks like overheating - artifaces and what not. Colors go awry and game is unplayable. Exit - windows also messed up. Rebooting fixed the problem. Now full release of HL2 and I play for about 20 min until the same thing happens. This time on reboot I get the same problems on my bios flash screen, windows load screen and windows. I take vid card out mess with it a bit to see if the cooling is off somehow. Couple tries and finally it boots to windows normal. Try HL2 again - bam same thing. Its at the point that soon as I boot (and this is after having the computer cool for a day) I get the wierd graphics. I think I burnt my card up.

So... 1 - could there just be something in HL2 that has corrupted my video card 2 - if my card just happened to die at release time of HL2 then what should I get 3 - on my new card, how do I make sure I can RMA it back if the same thing happens 1 year down the road




phoenizz

-

50 XP

3rd March 2008

0 Uploads

939 Posts

0 Threads

#2 15 years ago

that sux alot. call tech support to see if you can RMA the card or something.




Guest

I didn't make it!

0 XP

 
#3 15 years ago

i had the same problem, and what a coincidence it started once i started to play cs source also, i thought it was MY fault but turns out that i did NOTHING finaly someone else that this happend to, i already sent in my 9800 pro 128mb as a RMA and they sent me a new one, BUT what if it happends again with hl2@?!?!?! cause then i wont be able to RMA it any more




phoenizz

-

50 XP

3rd March 2008

0 Uploads

939 Posts

0 Threads

#4 15 years ago

well its a risk u have to take.




Blitz Krieger

Veritas Vincit

50 XP

5th December 2002

0 Uploads

390 Posts

0 Threads

#5 15 years ago

I've got the same card and haven't had any problems,yet.I only played CSS once for a couple hours,though.

What does RMA stand for,just in case? :uhoh:




nimo333

NIMO and NIMO333

50 XP

2nd October 2004

0 Uploads

389 Posts

0 Threads

#6 15 years ago

There is a lesson in that, go buy a Nvidia card, it is the most stable thing ever. I'm sorry, but I hate ATI cards, I've seen their performance and software programming and they suck at it.




Guest

I didn't make it!

0 XP

 
#7 15 years ago

Seems like the problem is driver related, it happened to my ATI Radeon X800, after I reinstalled the latest catalyst drivers, the problem fixed, (i knew it was drivers and not the card, because on boot-up, the graphics are fine, until windows loads the graphics driver)

Hope this helps