Problems with gmod -1 reply

Please wait...

FeelFree

[130.Pz]M.Frey

50 XP

15th September 2006

0 Uploads

5,610 Posts

0 Threads

#1 12 years ago

I downloaded garrys mod and started to install it and before the wizard came out it told me that i DONT HAVE steam and hl2.So i put it into the steam folder and started the installer again and again it told me that i dont have steam installed.So i countinued the setup and in the end it told me that garrys mod icon should appear in ''my games'' list and if not i should restart steam.I restarted steam and gmod wasnt there.Whats the problem?:confused::confused::confused::confused::confused:




pvt. Allen

I would die without GF

50 XP

20th July 2005

0 Uploads

5,654 Posts

0 Threads

#2 12 years ago

Welcome to the forums FeelFree. Hard to tell why it's happening, assuming you do have Half-Life 2 too. Maybe try verifing local game cache of hl2 and then install gmod again.




PC_Master

I live on Gaming Forums

50 XP

4th January 2006

0 Uploads

1,094 Posts

0 Threads

#3 12 years ago

Try installng with steam on and then off, and I think you need HL2 deathmatch to...but I'm not sure.

P.S. Welcome to the forums




pvt. Allen

I would die without GF

50 XP

20th July 2005

0 Uploads

5,654 Posts

0 Threads

#4 12 years ago

Hmm, yeah, that's true. You should have your Steam off and have the Half-Life 2: Deathmatch and Counter-Strike: Source installed.




17th November 2005

0 Uploads

189 Posts

0 Threads

#5 12 years ago

Make sure its being installed to the proper directory. After the installation is done, go into Valve/Steamapps/Sourcemods. There should be a folder in there titled Gmod or something. If there isn't one, then the installer is installing it to the wrong place, so try to find it, and simply copy it to the sourcemods folder. If its not a self installer, and its a zip file, and the folder is missing, then YOU are installing it to the wrong place. If it is being installed to the right place, and you have HL2/HL2DM/CSS, then I dunno whats wrong. PS: Is it just me, or is Gmod kinda problematic?




Skyrider

FileFront Network Staff

50 XP

7th June 2003

0 Uploads

2,058 Posts

0 Threads

#6 12 years ago

Steam is not required to be off. I Install all my mods with steam enabled, I only have to reboot for them to show up in the Steam Game list.




gyromorgian

GAAAAH HAHA! AHHHAHA!

50 XP

9th August 2006

0 Uploads

92 Posts

0 Threads

#7 12 years ago

Baron: It's not you. Whenever I try to load a saved game, it tells me the save file is corrupted. Which is a good thing to mention here. P.S. How do you change your account information, like picture and motto thing when you post these?




masamunect

ich bin gut

50 XP

10th October 2004

0 Uploads

73 Posts

0 Threads

#8 12 years ago

To play Garry's mod properly, you must have Hl2 ofcourse hl2dm and counter-strike source installed. And, It may help to make sure that Gmod is installing to the correct folder.




pvt. Allen

I would die without GF

50 XP

20th July 2005

0 Uploads

5,654 Posts

0 Threads

#9 12 years ago
gyromorgianP.S. How do you change your account information, like picture and motto thing when you post these?

When yuo're logged in you can notice Control Panel bar, right from the Home and under FileFront logo. There you can acces separately from the left menu bar profile options. Just have a look around.