Server wont show up... ! -1 reply

Please wait...

Dr X brain Insane

I'm too cool to Post

50 XP

9th May 2004

0 Uploads

5 Posts

0 Threads

#1 14 years ago

Hi .. I have a big problem so i hope some of you will please help me..:( I have just made my first dedicated server in jedi knight outcast. The program i use for the server: " jk2win32ded " My server is working just fine for other people, but i cant join it ... I have no idea why i cant, but the server just doesent show up under local, internet or favorites... Under local it just says: "Getting Info For Server ..." but no matter how long i wait my server doesent come up .. :(

I have no firewall or anything like that... I have heard that the server must not be in the same direction as where im playing from, and that i should copy the server to other direction, but i dont really know..... CAN SOMEONE PLEASE HELP ME ? That would be so nice :)




young Obi-Wan

I pretend I'm cooler than AzH

50 XP

17th October 2002

0 Uploads

4,137 Posts

0 Threads

#2 14 years ago

it doesn't matter which directory it is. just start the same JK2 MP again, and check the internet list for your server. it must be there ... sort the list by ping, because your ping will be 0 so the server will be at the top.




Dr X brain Insane

I'm too cool to Post

50 XP

9th May 2004

0 Uploads

5 Posts

0 Threads

#3 14 years ago

Yeah i have tried... but as i said.. it just doesent show up... :( :( :(




Shadowfire67

All your base are belong to us

50 XP

2nd February 2004

0 Uploads

596 Posts

0 Threads

#4 14 years ago

Are u doing the ded server from the "creat a server" button?




Dr X brain Insane

I'm too cool to Post

50 XP

9th May 2004

0 Uploads

5 Posts

0 Threads

#5 14 years ago

no im making it from windows..please help me =/




Amidala

Don't whine, respawn!

50 XP

26th September 2003

0 Uploads

505 Posts

0 Threads

#6 14 years ago

The problem is a port conflict. The default port for JK2 is 28070 (29070 for Jedi Academy). The server starts up using the default port (28070) and other people using different IP addresses can use the same port to join your server. However, when you start your client, it is on the same IP address as the server and it is trying to use the same default port (28070) that is already in use by the server, therefore it can't connect. You need to change the port used by your client. You can either:

  1. start your client, then open the console and enter /set net_port 28071, then refresh the server list
  2. Make a shortcut to your jk2mp.exe program, then in Properties change the Target line to read "C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\jk2mp.exe" +set net_port 28071 (assuming you installed in the default directory. Just add +set net_port 28071 after \jk2mp.exe". Then use the shortcut to start your client and the port will always be set to 28071.

You can still join other servers using port 28071 because servers will accept connections from ports 28070 to at least 28075 (maybe even higher, haven't tested those yet. I know that range will work), so you can always use port 28071 for your client. It's best to leave the server on the default port (28070).

In both cases your server will be listed under Local, not Internet (because it is Local to your client, and you aren't using the Internet to connect to it).




Gendaito

GF Pwns Me!

50 XP

19th May 2003

0 Uploads

62 Posts

0 Threads

#7 14 years ago

yarr its a local server. its on your LAN so get it from the locals, if you cant find it you might need to open up some stealth ports or alter the port in the target line




Dr X brain Insane

I'm too cool to Post

50 XP

9th May 2004

0 Uploads

5 Posts

0 Threads

#8 14 years ago

Thanks guys !! I will try the "port thing" right away :D .. Ill return if it wont help .. Hope it works =)




Dr X brain Insane

I'm too cool to Post

50 XP

9th May 2004

0 Uploads

5 Posts

0 Threads

#9 14 years ago

ok.. i tried the "direction thing" .. but it didnt work.. =( .. Im not sure that the problem is that i cant join, cause maybe i can join, my server just dont show up on the list when i refresh... Well... Some say that its my router that is the problem.. but i have no idea on how to fix it :(