Shaders problem -1 reply

Please wait...

MeusH

°•°•°•°•°•°•°•°•°

50 XP

16th November 2003

0 Uploads

3,282 Posts

0 Threads

#1 15 years ago

Hey. I need make shader with visible black picture, invicible white. I'm making shader, but white is still visible. So I've made .tga But it doesn't work, too!

Please, help me :beer:




Jadocran

I'm a Magic Wand.

50 XP

10th November 2003

0 Uploads

474 Posts

0 Threads

#2 15 years ago

sry cant help ya... i jsut begun working with shaders.. so i dont know much about them yet :p




Guest

I didn't make it!

0 XP

 
#3 15 years ago

textures/myimages/image1 { surfaceparm trans surfaceparm nonsolid { map textures/myimages/image1 blendFunc GL_ONE GL_ONE } { map $lightmap blendFunc GL_DST_COLOR GL_ZERO depthfunc equal } }




MeusH

°•°•°•°•°•°•°•°•°

50 XP

16th November 2003

0 Uploads

3,282 Posts

0 Threads

#4 15 years ago

Thanks Wade, now I will have to try it...




Guest

I didn't make it!

0 XP

 
#5 15 years ago

Actually hang on...I just realised I did the opposite of what you asked lol....

textures/myimages/image1 { surfaceparm nonsolid surfaceparm trans q3map_nolightmap { map textures/myimages/image1 blendFunc GL_DST_COLOR GL_ZERO } }

That blendFunc should ring a bell and then you'll realise just how easy that shader was.




Jadocran

I'm a Magic Wand.

50 XP

10th November 2003

0 Uploads

474 Posts

0 Threads

#6 15 years ago

surfaceparm nonsolid

does that ´make it nonsolid (need for some data u can go through :p)




Guest

I didn't make it!

0 XP

 
#7 15 years ago

Yes it does, stuff like this I'd recommend you make nonsolid then use physics_clip or clip to block off the bits you want.




MeusH

°•°•°•°•°•°•°•°•°

50 XP

16th November 2003

0 Uploads

3,282 Posts

0 Threads

#8 15 years ago

Okay. It works, thanks. But it works only at one thing. Never mind, thanx!