Timescale -1 reply

Please wait...

Thanos42

I'm too cool to Post

50 XP

4th February 2004

0 Uploads

2 Posts

0 Threads

#1 14 years ago

Hello,

I am unable to change the timescale in either 1.3 or 1.4. I have tried on both Mac and PC on multiple computers. I am using this command /seta mod_timescale "0.3" or /seta mod_timescale ".3"

It seems to make the change, but the game never slows. Is there something I am doing wrong? I believe I am following the manual precisely. Any suggestions?

Thanks, thanos42




LeeOattes

Duelers Mod developer

50 XP

4th April 2003

0 Uploads

128 Posts

0 Threads

#2 14 years ago

Mod_timescale is a left over from the base jedimod code. I can't remember if it actually worked there, but it definitely does nothing at all in duelers. You can set it, but the game does not use it at all ;-).

Now, to do what you want to do, try setting g_speed. The default is 250. It should work like changing g_gravity (default is 800 -- set it to 200 for low gravity or 1200 for high gravity). Setting g_speed to a smaller value ought to slow down the game. I have not tried this myself, but I do use this mechanism to enable the realistic scaling where players move fast or slower depending on their size, so it should work!




Thanos42

I'm too cool to Post

50 XP

4th February 2004

0 Uploads

2 Posts

0 Threads

#3 14 years ago

Thanks Lee. It didn't quite work how I was hoping. What the code did was modify how fast the characters move around, while not changing their animations. So they would move very slowly while still appearing to run at full speed. Then if you executed a DFA, it would be at full speed, as would rockets, jumps, etc. The low gravity is pretty fun though. Thanks!

Thanos