can't see my own server... 62 replies

Please wait...

Inskipp

GF Pwns Me!

50 XP

2nd April 2003

0 Uploads

51 Posts

0 Threads

#1 16 years ago

I have a legit copy of the game, for starters. I can run a dedicated server easily enough, using the +set dedicated 2 on the command line, and I can see it on another local computer, and people from the internet are connecting, but I can't play myself!

Any one know why this might be? A cvar or something?




Soral

I'm too cool to Post

50 XP

19th September 2003

0 Uploads

7 Posts

0 Threads

#2 16 years ago

InskippI have a legit copy of the game, for starters. I can run a dedicated server easily enough, using the +set dedicated 2 on the command line, and I can see it on another local computer, and people from the internet are connecting, but I can't play myself!

Any one know why this might be? A cvar or something?

Hi, I think I have pretty much the same problem as you, I run the dedicated server pretty well, people are connecting to it. But the problem is, JK3 CLIENT is using the same port as the Dedicated server I think. So I cant see ANY servers when I run my server. All this trying to run on the same client machine. Server + Client, I did that everytime with JK2, and JK3 wont let me.. It's weird, if anyone got any solutions beside of having the server on another comp, or buying a server, please reply. Thank you, or feel free to post any comments. Thanks!

- Soral




Inskipp

GF Pwns Me!

50 XP

2nd April 2003

0 Uploads

51 Posts

0 Threads

#3 16 years ago

On page 41 of the manual, it says you can not run a dedicated and play on the same system. RTFM Inskipp. Oh wait, I am Inskipp.

Ok, so we need a mod? Help us modders!!!?!




Soral

I'm too cool to Post

50 XP

19th September 2003

0 Uploads

7 Posts

0 Threads

#4 16 years ago

InskippOn page 41 of the manual, it says you can not run a dedicated and play on the same system. RTFM Inskipp. Oh wait, I am Inskipp.

Ok, so we need a mod? Help us modders!!!?!

You can.. you need to have your dedicated server on a different port, than your Jedi Knight 3 client so in the command line of your shortcut it would look like the following :

"C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\jampDed.exe" +set net_port 29071 +exec server.cfg

see the +set net_port I changed it to 29071 cuz JK3 is using 29070 by default, this is why you cant see any servers while yours is up. There you go, have fun.. I cant get to see it listed tho but people are connected to it.. I can connect to my server too, to play with others.. I just cant see it into the free for all listing.... bah. needs a patch.. master server is screwed up.




Inskipp

GF Pwns Me!

50 XP

2nd April 2003

0 Uploads

51 Posts

0 Threads

#5 16 years ago

SoralYou can.. you need to have your dedicated server on a different port, than your Jedi Knight 3 client so in the command line of your shortcut it would look like the following :

"C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\jampDed.exe" +set net_port 29071 +exec server.cfg

see the +set net_port I changed it to 29071 cuz JK3 is using 29070 by default, this is why you cant see any servers while yours is up. There you go, have fun.. I cant get to see it listed tho but people are connected to it.. I can connect to my server too, to play with others.. I just cant see it into the free for all listing.... bah. needs a patch.. master server is screwed up.

Excellent, mine now works. I can see it listed under local servers, and connect and play. I knew about the net_port variable, but not how to use it.

Thanks for the help!




JediMouse

I'm too cool to Post

50 XP

18th September 2003

0 Uploads

8 Posts

0 Threads

#6 16 years ago

InskippExcellent, mine now works. I can see it listed under local servers, and connect and play. I knew about the net_port variable, but not how to use it.

Thanks for the help!

Well, I still can't figure out what's up with mine.

I'm not running a dedicated server or a LAN server. I just launch my room when I want to play, and it doesn't show up on the list.

I'm not behind a router or a firewall or anything. It just seems JA doesn't recognize the room 90-95% of the time.

I launch a simple duel room, 4 player slots, pure server, min ping 0, max ping 175, max rate 5000, no password....etc, etc.

My settings have been the same from day 1. When it "works", people are logging in literally once per minute.When it's not working, I can sit there for a hour, two hours, and not even a single person will attempt to connect.

And there simply aren't enough duel rooms up yet for that to happen. Something is funny.




Josh_-_-9

Slightly cooler than a n00b

50 XP

21st September 2003

0 Uploads

24 Posts

0 Threads

#7 16 years ago

SoralYou can.. you need to have your dedicated server on a different port, than your Jedi Knight 3 client so in the command line of your shortcut it would look like the following :

"C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\jampDed.exe" +set net_port 29071 +exec server.cfg

see the +set net_port I changed it to 29071 cuz JK3 is using 29070 by default, this is why you cant see any servers while yours is up. There you go, have fun.. I cant get to see it listed tho but people are connected to it.. I can connect to my server too, to play with others.. I just cant see it into the free for all listing.... bah. needs a patch.. master server is screwed up.

i still can't get mine to work......... maybe if someone could tell me how to do it. just to make sure i did it right. please!




Nimmo

I don't spend enough time here

50 XP

5th June 2003

0 Uploads

16 Posts

0 Threads

#8 16 years ago

SoralYou can.. you need to have your dedicated server on a different port, than your Jedi Knight 3 client so in the command line of your shortcut it would look like the following :

"C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\jampDed.exe" +set net_port 29071 +exec server.cfg

see the +set net_port I changed it to 29071 cuz JK3 is using 29070 by default, this is why you cant see any servers while yours is up. There you go, have fun.. I cant get to see it listed tho but people are connected to it.. I can connect to my server too, to play with others.. I just cant see it into the free for all listing.... bah. needs a patch.. master server is screwed up.

Do you mean in the Properties>Target? Cause when I tried that it wont work.




[nWo] Filth

Whiner

50 XP

22nd September 2003

0 Uploads

28 Posts

0 Threads

#9 16 years ago

Im not sure if i understand all this. What did u do ? rename the shortcut?




Inskipp

GF Pwns Me!

50 XP

2nd April 2003

0 Uploads

51 Posts

0 Threads

#10 16 years ago

Let me try to be a little clearer.

Make a shortcut to jamp.exe

right click it, and go to properties, in the target box, add this:

+set net_port 29071

so that it looks like this:

"C:\Program Files\Lucasarts\Star Wars Jedi Knight Jedi Academy\GameData\jamp.exe" +set net_port 29071

Then use that shortcut to play. You can name the shortcut whatever you want.