Quake 4 on Vista -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 11 years ago

Hi there, I have just installed Quake 4 on Vista 64 Ultimate with the latest 1.4.2 patch. When go to multiplayer to play online the game will play fine for about 10mins then the screen will go black and just sit there. Then i will get a pop up on my start menu saying "the video driver has stopped working". The same thing happens in single player. I'm running a Intel quad core CPU, 2 X 8800GTX SLi with a resolution of 1920x1200. Also i'm running the latest 163.75 drivers. I can play all my other games fine without any problems, this is really the only game that i've had problems with on Vista :uhoh:.

Any help is greatly appreciated, thanks!.




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#2 11 years ago

Hello, try this...:

Remove or better rename the Quake4config.cfg and Autoexec.cfg (if any) files that are into the folder mod you are running or if you does not use any mod remove it or better rename it from the q4base folder.

When you re-start Q4, set your preferences to your taste and start playing. :)

If you are still having problems, then copy only my Autoexec.cfg file from any of my latest mods (Enhanced Shaders v1.0 for example, available on Quake 4, Quake 4 Downloads - FileFront.com) to q4base folder.

When you re-start Q4, set your preferences to your taste and start playing.

I hope this is of any help for you and maybe others. :)




Guest

I didn't make it!

0 XP

 
#3 11 years ago

Hi thanks for your help....

I tried what you suggested and i played quake 4 for about 10 mins and it's still the same, not sure what could be wrong. It plays perfectly fine then all of a sudden i get a black screen and it crashes. I've heard other people get it to work no problems, so i don't know what could be wrong. I dont have any problems with any other games.

Do you have any other ideas of what it could be?. thanks again.




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#4 11 years ago

Well, i have Win Vista 32 Premium and i have problems with any Quake IV version higher than v1.04beta, why ??? I don't know, but maybe you have to disable the CPU Quad-Core feature option on the Q4 game, i think this will be the cause for your problems.




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#5 11 years ago

I was having problems with Quake IV patched to anything higher than v1.04beta with another PC also and with Win XP SP2, for example the fire particles and FX disappearing at random times ¿? Why ??? I think this will have to be with CPU Dual Core support on higher versions than v1.04beta !




Guest

I didn't make it!

0 XP

 
#6 11 years ago

hi again, thanks for your reply...

I have the muti core option disabled in the settings. The game will crash with it on or off, right now i have it off. With it on i dont see any difference in performance anyway.

I haven't tried any other patches except the latest 1.4.2 patch, since most server require you to have this.

When i installed the game it said "this version of this game is incompatible with windows Vista", but othe people have had the same warning, but dont have problems.

Not sure what else to do...might just to forget about :(... it is just one game after all. Other games work fine.

Thanks for your help.




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#7 11 years ago

I will investigate on that, you don't have any mod installed into q4base, right ???

The mods should be into Quake 4 root folder, never on q4base folder.

Maybe re-installing it again... :(

In the NVidia settings, do you have set the options to use OpenGL games, this is needed to use any D3 engine games, like D3, Q4, Prey or ETQW !




Guest

I didn't make it!

0 XP

 
#8 11 years ago

hi again...

No i never use mod's....i thought it could be something to do with OpenGL, i never thought to look in the nvidia settings. I had a look and i saw something called "conformant texture damp" and it was set to "use hardware" so i set it to "use OpenGL". Is that the right setting?.

I'll give it a try now and see if it has solved the problem.

thanks.




Guest

I didn't make it!

0 XP

 
#9 11 years ago

I just tried it again and it was the same...i also set quake 4 to run in single card mode, but this time it froze at the loading screen going into the a server, but i could still hear myself moving in the background.... very werid : /.




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#10 11 years ago

Try opening the console in game and switch gfx modes with...:

r_renderer xxx

Where xxx can be best arb2 arb nv10 nv20 nv30 r200 and others...

Try also to do a cvar_restart to restart the variables to it's defaults.