Getting Better Performance out of UT2K3 -1 reply

Please wait...

Metz

X2DesignStudios

50 XP

8th May 2003

0 Uploads

10 Posts

0 Threads

#1 15 years ago

Unreal Tournament 2003 is on default using the Direct3D Rendering Device, and doesnt let you choose OpenGL. Direct3D is suppose to be better looking but you can barly tell a diffrence versus OpenGL and OpenGL is a hell of lot faster. Here is how to change your game to run under OpenGL.

Open your UT2003.ini file inside your UT2003/Sytem/ folder (eg. C:\UT2003\System\) 3rd section down you should see a few lines that look like this:

RenderDevice=D3DDrv.D3DRenderDevice ;RenderDevice=Engine.NullRenderDevice ;RenderDevice=OpenGLDrv.OpenGLRenderDevice

The 1st line indicates which device to use. the other 2 with the ; in front show which other devices are avaible but are not being used. Now what you need to do is copy this part of the 3rd line: "OpenGLDrv.OpenGLRenderDevice". Then you need to paste it over "D3DDrv.D3DRenderDevice" on the first line and then replace the old 3rd line with "D3DDrv.D3DRenderDevice". So it should look exactly like this:

RenderDevice=OpenGLDrv.OpenGLRenderDevice ;RenderDevice=Engine.NullRenderDevice ;RenderDevice=D3DDrv.D3DRenderDevice

Another thing you can do for optimal performance is take the FPS cap off that limits users to only achieve 90 FPS. With this option false you can let your hardware shine. Here is how to do it:

Open your UT2003.ini, its a little over half way down and its under a section that looks like this:

[Engine.LevelInfo] PhysicsDetailLevel=PDL_High bLowSoundDetail=False DecalStayScale=2.000000 bNeverPrecache=false bCapFramerate=True - Change this line to Flase. bShouldPreload=False

So it should look exactlly like this:

[Engine.LevelInfo] PhysicsDetailLevel=PDL_High bLowSoundDetail=False DecalStayScale=2.000000 bNeverPrecache=false bCapFramerate=False bShouldPreload=False

Now your save your UT2003.ini and enjoy better frames :)

Also make sure you have anti-aliasing and anisotropic filtering turned off and vertical sync on both OpenGL and Direct3D turned off.