Need help getting RtCW to run in Win7 64 bit -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 7 years ago

Hi, I recently decided to install my RtCW:GotY edition on my new Win7 64bit system. It installed with no probs into the default x86 folder. When I tried to run single player directly, it started loadup screen, the green box with the list of .pak files and such, but crashed on the main program startup. I then tried to run it using the Windows XP SP3 compatibility setting, which is what my old system was, using the troubleshoot compatibility option. The console said it couldn't load default.cfg at the top and gave this list:

Wolf 1.32 win-x86 May 1 2002 ----- FS_Startup ----- Current search path: C:\Windows\system32/main

---------------------- 0 files in pk3 files ----- CL_Shutdown ----- ----------------------- Couldn't load default.cfg

If I goto properties and try using the compatiblity tab, the console loads up and the program crashes again. What's weird is that multiplayer runs fine. I tried going to single player from multiplayer, but it said it couldn't load the single player game. It didn't crash, just refused to load single player. Has anyone got this game to work in Win7 x64 at all? I've been looking for the default.cfg file, but I can't find where it was installed and I'm positive that's the key to getting single player to work.




Guest

I didn't make it!

0 XP

 
#2 7 years ago

In addition to having a compatibility mode enabled, make sure to enable administrative privilege level as well and to disable Desktop Composition (all done on the executable file of the game, Compatibility tab) before running the game. That usually solves this kind of problem, but I don't know if it'll work for you too. For some reason, it doesn't work for everyone.




vicpas

I don't spend enough time here

50 XP

22nd March 2008

0 Uploads

28 Posts

0 Threads

#3 7 years ago

Try this "Default" file. [COLOR=red]//[/COLOR] [COLOR=red]// KEY BINDINGS[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]unbindall[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]// weapons[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]bind 1 "weaponbank 1"[/COLOR] [COLOR=red]bind 2 "weaponbank 2"[/COLOR] [COLOR=red]bind 3 "weaponbank 3"[/COLOR] [COLOR=red]bind 4 "weaponbank 4"[/COLOR] [COLOR=red]bind 5 "weaponbank 5"[/COLOR] [COLOR=red]bind 6 "weaponbank 6"[/COLOR] [COLOR=red]bind 7 "weaponbank 7"[/COLOR] [COLOR=red]bind 8 "weaponbank 8"[/COLOR] [COLOR=red]bind 9 "weaponbank 9"[/COLOR] [COLOR=red]bind 0 "weaponbank 10"[/COLOR] [COLOR=red]bind ] weapprev[/COLOR] [COLOR=red]bind [ weapnext[/COLOR] [COLOR=red]bind \ +mlook[/COLOR] [COLOR=red]bind ENTER +activate[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]// CHARACTER CONTROLS[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]bind CTRL +attack[/COLOR] [COLOR=red]bind ALT +strafe[/COLOR] [COLOR=red]bind SHIFT +sprint[/COLOR] [COLOR=red]bind CAPSLOCK +speed[/COLOR] [COLOR=red]bind - zoomout[/COLOR] [COLOR=red]bind = zoomin[/COLOR] [COLOR=red]bind , itemprev[/COLOR] [COLOR=red]bind . itemnext[/COLOR] [COLOR=red]bind ' +useitem[/COLOR] [COLOR=red]bind DEL +lookdown[/COLOR] [COLOR=red]bind PGDN +lookup[/COLOR] [COLOR=red]bind END centerview[/COLOR] [COLOR=red]bind SPACE +moveup [/COLOR] [COLOR=red]bind a +moveleft[/COLOR] [COLOR=red]bind b +zoom[/COLOR] [COLOR=red]bind c +movedown[/COLOR] [COLOR=red]bind d +moveright[/COLOR] [COLOR=red]bind e +leanright[/COLOR] [COLOR=red]bind f +activate[/COLOR] [COLOR=red]bind g +kick[/COLOR] [COLOR=red]bind n notebook[/COLOR] [COLOR=red]bind q +leanleft[/COLOR] [COLOR=red]bind r +reload[/COLOR] [COLOR=red]bind s +back[/COLOR] [COLOR=red]bind w +forward[/COLOR] [COLOR=red]bind x +kick[/COLOR] [COLOR=red]bind z weapalt[/COLOR] [COLOR=red]bind UPARROW +forward[/COLOR] [COLOR=red]bind DOWNARROW +back[/COLOR] [COLOR=red]bind LEFTARROW +left[/COLOR] [COLOR=red]bind RIGHTARROW +right[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]// MOUSE OPTIONS[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]bind \ +mlook[/COLOR] [COLOR=red]bind MOUSE1 +attack[/COLOR] [COLOR=red]bind MOUSE2 +moveup[/COLOR] [COLOR=red]bind MOUSE3 weapalt[/COLOR] [COLOR=red]bind mwheelup weapprev[/COLOR] [COLOR=red]bind mwheeldown weapnext[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]// CLIENT ENVIRONMENT COMMANDS[/COLOR] [COLOR=red]//[/COLOR] [COLOR=red]bind PAUSE pause[/COLOR] [COLOR=red]bind ESCAPE togglemenu[/COLOR] [COLOR=red]bind ~ toggleconsole[/COLOR] [COLOR=red]bind ` toggleconsole[/COLOR] [COLOR=red]bind TAB +scores[/COLOR] [COLOR=red]bind F4 +scores[/COLOR] [COLOR=red]bind F5 savegame quicksave[/COLOR] [COLOR=red]bind F9 loadgame quicksave[/COLOR] [COLOR=red]bind F11 screenshot[/COLOR] [COLOR=red]seta name "WolfPlayer"[/COLOR] [COLOR=red]seta m_side "0.25"[/COLOR] [COLOR=red]seta m_forward "0.25"[/COLOR] [COLOR=red]seta m_yaw "0.022"[/COLOR] [COLOR=red]seta m_pitch "0.022"[/COLOR] [COLOR=red]seta cl_freelook "1"[/COLOR] [COLOR=red]seta cl_mouseAccel "0"[/COLOR] [COLOR=red]seta sensitivity "5"[/COLOR] [COLOR=red]seta cl_run "1"[/COLOR] [COLOR=red]seta cl_pitchspeed "140"[/COLOR] [COLOR=red]seta cl_yawspeed "140"[/COLOR] [COLOR=red]seta g_gameskill "1"[/COLOR] [COLOR=red]seta cg_autoswitch "2"[/COLOR] [COLOR=red]seta cg_quickMessageAlt "1"[/COLOR] [COLOR=red]seta cg_drawCompass "1"[/COLOR] [COLOR=red]seta cg_useWeapsForZoom "1"[/COLOR] Copy these sentences with notepad, save and rename the file to "default.cfg" without quotes and place it on Main folder. If you have GL problems try it: ::: RTCW4EVER - WOLFENSTEIN AREA ::: - ReMOSitory