Problems Loading DX10 Lighting on DX11, Dreaded X-Ray Engine Crash -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 8 years ago

Hey guys,

I have spend the last three days seeking an answer to this issue I'm having, and have yet to actually conclude what can be done. I have, however, figured out the exact cause of the ctd, but still haven't found a way to fix it without going down to DX 9 Lighting. I am running DX11 on:

Intel Core 2 Quad (Q9550 @ 2.83GHZ) 4 Gbs of RAM ATI RADEON (Sapphire) 4870x2

All drivers updated within the last month to current versions and, as mentioned, DX11 No other games that I have played on this system have had anything similar happen. This has been the most stable system I've ever owned, so it is relatively rare (since Win 7) for me to see issues of this sort pop up.

The issue: I installed the game, the game autodetected my settings to Maximum, and started up fine. The first scene played normally, then the game began just fine.

I closed out of the game after playing a few moments to do something else, then came back later to restart the game for the heck of seeing the beginning again. Everytime I tried to start a new game, the game crashed with that lovely common error "x-ray Game engine has encountered an error", etc. I tried loading my previous save, and it loaded ok. I then closed out of the game and deleted all of the Stalker files in the "Public" docs folder to see if a clean regen and restart would fix the new game issue. Doing so fixed it, however, I only realized after that it was because the game settings were set to Medium since the settings were deleted. After a little messing with the settings, I came to conclude with certainty, that it was the Enhanced Dynamic Lighting DX10 which was causing the crash. I backed up the autodetect ltx in the docs folder to use for ref. The one change that made the difference was changing the Enhanced Dyn Lighting to the non DX10 version. Other than that, all settings stayed the same.

(Just to note: After reinstalling the game, then trying to load my initial saves that were made with DX10 and loaded a couple of times, I was unable to ever get those saves to load again.)

I verified it over and over and over, just to make sure. Not a single time did it load. The thing that baffles me is that it DID load the first time, on the exact same autodetected settings. I remember seeing the DX10 Lighting enabled because I never used to have that capability until this system! So, I was happy that it was my turn to have a snazzy looking game. ;) SO, to try to fix things and start from scratch, I went ahead and uninstalled the entire game, deleted all files from the Pub Docs folder again, and even went as far as to install DX11 to make sure it was up-to-date. Still, the game, after reinstall, refused to allow me to play with the DX10 settings. I have noticed that I have to go into Processes to end the Xrengine process every time the game crashes, though that likely has no relevance here.

Sure, the game looks nice without DX10 Lighting, but I didn't get this system to setting for DX 9 lighting! ;) After searching and searching, I just wasn't able to find a conclusive answer to my specific problem. Since I know the cause of the crash, but just don't know how to fix it. (Other than using DX 9, which I am doing for the time being)

I have no mods, I have no issues with other games, I have a fresh install of the game, and my specs meet all requirements. What am I missing? I can't imagine that the answer is too obscure, but I'm just not finding it with all of the "x-ray crashed!" threads on the google globe. I would be forever indebted to whomever was able to lend some useful advice. Sorry, ALL advice is useful. I should save "usable" advice, directly pertaining to fixing this issue.

Thanks ahead of time! Let me know if there is some other clarification I may have missed.

Overview of things: (My system settings as stated above) Intel Core 2 Quad (Q9550 @ 2.83GHZ) 4 Gbs of RAM ATI RADEON (Sapphire) 4870x2

Running: Windows 7 Home (6.1 Build 7600) (legit) DX11 non-Steam, Retail Version (legit) No Mods

Things done besides what was mentioned above: Restarted System in between changes SCOURED GOOGLE Force Quit the XREngine every time SCOURED GOOGLE

Thank you, even if you just read through to the end of this. :) I will appreciate any assistance.




smrtphoneusr

The forums staffers think I'm Cool

50 XP

22nd November 2009

0 Uploads

171 Posts

0 Threads

#2 8 years ago

post the fatal error from the end of the log file (there is a logs folder in your public documents)