Bad-Motha MODs for CS -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#41 11 years ago

on a strange note... I took the values from your auto-beretta w_beretta.ltx

and used them to make a FULLauto version of the 1911 colt 45 (at 450 RPM) with 17 round clip upgraded~ and it works no problems.... the game crashes when the beretta file is in there though... weird.




Bad_Motha

Pro-Filer thinks I'm cool!!

50 XP

10th May 2008

0 Uploads

435 Posts

0 Threads

#42 11 years ago

Well what all did you change to make the 1911 work? All you should have needed to change was make the weapon type an LR300 (because making it any type of pistol won't allow for 3 round burst or full-auto modes) Then you just need to change the fire modes (1 = single; 3 = burst; -1 = auto) Don't change the fire modes down at the very bottom of the file though, this is for the shooting game @ Duty base. When I change this to anything but a 1, it crashes the game. Then in the upgrade file, I changed the values for the mag upgrade. Besure to change both numbers listed as there is a +## value and a plain ## below that. Both need to be changed.




Bad_Motha

Pro-Filer thinks I'm cool!!

50 XP

10th May 2008

0 Uploads

435 Posts

0 Threads

#43 11 years ago

Well I'm about to release a fix that will help with people who were having troubles with MP5 & Beretta that I changed. But I still can't get the MP5 to stay pointed in the middle of the screen when you have your detector out. Can someone help me with this? I'm wondering if there is a detector file somewhere that has settings in there for different weapons. This might be my problem. The guns work great regardless, just that the MP5 points to the right when the detector is equipped. When shooting though it then points to the correct position and all.




Bad_Motha

Pro-Filer thinks I'm cool!!

50 XP

10th May 2008

0 Uploads

435 Posts

0 Threads

#44 11 years ago

Also if anyone has a saved game where you are far in the game, can you do a test for me? My level changer should allow the player to come back to Red Forest from Limanak. I just need to know if it works properly as I havn't had the change to venture there yet.




An1m4l

GF Pwns Me!

50 XP

19th September 2008

0 Uploads

51 Posts

0 Threads

#45 11 years ago
Bad_Motha;4597943Well I'm about to release a fix that will help with people who were having troubles with MP5 & Beretta that I changed. But I still can't get the MP5 to stay pointed in the middle of the screen when you have your detector out. Can someone help me with this? I'm wondering if there is a detector file somewhere that has settings in there for different weapons. This might be my problem. The guns work great regardless, just that the MP5 points to the right when the detector is equipped. When shooting though it then points to the correct position and all.

I actually thought it looked kinda cool pointing the gun away with the detector out! BM can you tell me if theres a file i delete or a value i can change somewhere to lower the flashlight distance? I know it affects my flashlight and NPC's, but i dont mind, i just want to lower it down a bit, or if thats not possible just remove it




Bad_Motha

Pro-Filer thinks I'm cool!!

50 XP

10th May 2008

0 Uploads

435 Posts

0 Threads

#46 11 years ago

The flashlight file is under... \gamedata\configs\models\objects\light_night.ltx Just change the first two values. They represent the overall lighting in meters. Change it down to around 20 - 40. Long as you make both ## values the same. The first is for Render1 (R1), second is for Render2 (R2). Anything less then 20 and it's just about as useless as the vanilla flashlight. If there is a display problem with the NPC; i.e. doesn't display correctly or displays a white blob infront of the character; Go to Options > Advanced > uncheck the NPC Flashlight box (so it's not yellow). Then load up a saved game. Once the game loads up, go back into options and turn NPC Flashlight back on. Now reload the same saved game. This should flush the game's cache and force it to re-sync correctly. I've had the "white-blob" or "white-out" effects on NPCs before when changing my light_night.ltx settings before (only in CS) and doing the trick I mentioned above seemed to fix it everytime, don't ask me why.