yet another crash problem (fang) -1 reply

  • 1
  • 2

Please wait...

chester7420

I don't spend enough time here

50 XP

22nd September 2008

0 Uploads

15 Posts

0 Threads

#1 10 years ago

alright. i was not aware CS had come out untill i saw it in a Gamestop. the guy at the gamestop even looked it up on his computer, and said it was not out yet. i saw it right before i left at the bottom of the ps3 section. i would expect alot more hype on CS, Especially concidering how amazing Shadow of Chernobyl was and still is. so i picked CS up and went home to see if it was anything. i run a vista 64bit system, so i was pepared for the worst. i started by not being able to see anything but glitchy images that repeated themselfes when i moved. then i found the 1.504 patch. this fixed that problem but i was not aware of the amount of problems still in the game. the first crash was when i tried to travel(by foot) to the garbage.i installed CS on my older XP computer and i was then able to move to the garbage.(from now on, im on the XP computer) the second crash was at the part where you have to get up on the rocks to fight off the pack of blind dogs. i just tried again and i was able to complete that part with no problems. Ok, now is the part with Fang. POSSIBLE SPOILER!!! the crash that i CANNOT get past is right after you enter the room where you get flashbanged and find yourself on the floor with 2 bandits talking above you, and you get all of you money and items stolen. so i find fangs PDA thing and i exit the room. then i get all the info for my next move over the radio and right when the transmission ends, i get the bug alert and my game closes. i have tried about 12 times and it crashes in the same spot. im just waiting for a patch to see if it will fix it. if anyone has any info on fixing this, i would be very appreciative




Supernatur4L

Resident Stalker

50 XP

23rd July 2008

0 Uploads

615 Posts

0 Threads

#2 10 years ago

Well number one you should work a little on formatting your thread as it is barely readable. Number two we need the error log that the game generates, specifically the very bottom part that says *FATAL ERROR*

This log can be found in \Documents and Settings\All Users\Documents\STALKER-STCS\logs\ xray_.log

Pretty much the only file youd be able to open anyways. If you're not sure about what to post, you can post the whole log but please do it using the [ SPOILER][/SPOILER ] tags. One goes in the front of the text you want to hide and the other behind it, and make sure to remove the spaces between the brakets.




chester7420

I don't spend enough time here

50 XP

22nd September 2008

0 Uploads

15 Posts

0 Threads

#3 10 years ago
Spoiler: Show
CRASH3.jpg it reads:FATAL ERROR [error]Expression : fatal error [error]Function : CScriptEngine::lua_error [error]File : E:\priquel\sources\engine\xrServerEntities\script_engine.cpp [error]Line : 180 [error]Description : [error]Arguments : LUA error: ....e.r. - clear sky\gamedata\scripts\xr_effects.script:1607: attempt to index field '?' (a nil value)



Supernatur4L

Resident Stalker

50 XP

23rd July 2008

0 Uploads

615 Posts

0 Threads

#4 10 years ago

You should have actually copy pasted instead of using the screenshot but youve got us the right part of the error code.

Someone said HERE that the problem maybe low virtual memory or lack of ram. Personally i think ive only gotten one CTD and thats because ive been playing for a while and maybe my GPU overheated although i doubt it.

Also a quick search has brought me to this fix Can't enter the Garbage: X-Ray Bugtrap - VALUE5games Forum but you're going to need to extract game files in order to fix it. I dont know if you've done that or not yet. If no, ill tell you how to.

Its a little late here, if you havent unpacked them then ill edit my file and upload a fixed copy.




WARCATT

I'm Working on it!!!

50 XP

14th September 2008

0 Uploads

424 Posts

0 Threads

#5 10 years ago

I not sure if this helps but...I ran into a crash problem, enough for the PC to restart it self. I had been having somewhat of a issue though with the graphics card I have. so I went to static, shut off anilisting, alouwed ansto just a little and toned down the detail alittle not alot, so nothing is maxed out and it didn't hard crash anymore. Also I stayed with the story line main mission and never side tracted. All in all I finished this game already..no patches, 3 mods= 1 trader / 1 weight / 1 no dynamic cross hair. ( I never use it, not even in SOC ). AMD 64x 1.89Gb CPU single core 2 gig ram 160 gig HD SATA ATI pro 512mb ( pro my ass, crashes in sub hunter 3, crashes star wars galatic battle grounds ) MB by gigabyte w/ Nvida chip set simple standard XP home edtion sp2 no updates except Inet 7 and media player 10 ( or is it 11? )




Bad_Motha

Pro-Filer thinks I'm cool!!

50 XP

10th May 2008

0 Uploads

435 Posts

0 Threads

#6 10 years ago

I have noticed, yet again ATI fails to deliver drivers that are better then the last. Sometimes it's hit and miss with them. Try the new ATI Catalyst Drivers 8.9 as people have reported better stability and much better FPS with these new drivers. Also after you get them setup, go into the Advanced Catalyst Control Panel and disable Catalyst A.I. under [+]3D section, also while you're in there, be sure that the following Direct3D options are checked "Enable Geomotry Instancing" and "Support DXT Texture Formats" Always uninstall old ATI drivers using the ATI - uninstall software option in Add/Remove Programs in Windows Control Panel. Then restart windows. You may want to disable your internet connection before restarting windows, so when it finds your Video Card as a new device, it doesn't try to download any ATI drivers from Windows Update website. Also when New Hardware does come up, just hit cancel. Then install your new ATI Drivers.




WARCATT

I'm Working on it!!!

50 XP

14th September 2008

0 Uploads

424 Posts

0 Threads

#7 10 years ago

[quote=Bad_Motha;4592300]I have noticed, yet again ATI fails to deliver drivers that are better then the last.quote] Actully I was using ATI 128mb Xasty card, very great card, never had a crash due to a graphics card issue. BUt the first time I played SOC ( I got the game 2 weeks or so after its release ) I toned it down alot but it still played great, untill I was out side furnace 4 after telling the c-conces project what to do with it self ( I didn't trust the wish master nor the BS from the hallogram ) and right there I had some real vid lagg! I mean the kind that makes you say " Oh come on, What the F--- is this? " I am a good sport and played out the new ending in the most stop flash still game ever played, ( picture 10 sequences out of 10 you only see the first, fith, 10th, each of them have lagged hanging there for almost a minute apeice..AUGH! ) earlier this year I discoverd the ATI pro w/512 mb telling me best game card, the xasty card was very good, so I got it, For the first time I could play the ending normal but a new flow of problems started that I hadn't had before.. I started DOOM3 and after the begging part it dumped, same for Quake, Silent hunter 3, Star wars Galatice Battle grounds ( like this game realy needs 128 mb to play muchless 512 mb to dump it. ) I adjusted everything down, Doom3 will play but not well and silent hunter 3 will dump if I get alot of ships on the map, no luck for Quak muchless STGBG. Oh yeah I got a star trek game that won't work right unless it is tunned way down, like the 128 mb card, and it requiers max to be 256. But I can play that stalker game fine, if I use the dynamic lighting it will prepdump 0-k on me every 15min or so, did that even in SOC.. I will check out that driver list




Supernatur4L

Resident Stalker

50 XP

23rd July 2008

0 Uploads

615 Posts

0 Threads

#8 10 years ago

Thats most likely because in the last levels they introduce teleport particle effects and theres a good number of them, not to mention quite an open and large level, thats why your card started to lag.




dra6o0n

Slightly cooler than a n00b

50 XP

17th September 2008

0 Uploads

39 Posts

0 Threads

#9 10 years ago

It would seem like more crashes are related to memory, but what about background program usage?

I Disliked Vista's usage of "FREE" Ram... It sucks up all the Free Memory of your ram, around 2GB if you use 3, and puts it somewhere "claiming" to make it process it more efficiently. Sometimes what happens is that the Free Memory will end up less than 1GB even though no programs are running.

And I made a thread on my theory of sudden programs and startup programs.




Bad_Motha

Pro-Filer thinks I'm cool!!

50 XP

10th May 2008

0 Uploads

435 Posts

0 Threads

#10 10 years ago

When running SOC & CS I make sure to have no programs running in the backround. I even close EXPLORER.EXE (from task manager) right after launching the game from my desktop shortcut. Out of 1.5GB of ram, I have approx. 1.2GB free before I launch either of the Stalker games. Both Stalker games run pretty well for me and I've had minimal crash problems. I'm running XP PRO (SP2) 32-bit. I also disable anything in startup, except for my ATI tray tools and my Creative Volume Control for XFI. I also disable XP Security Center, Auto-Updates, and the Clock Sync XP has. I use ATI Radeon X850 Platinum 256MB GDDR3 AGP8X. I set my BIOS AGP Aperture size to 256MB. I'm using Catalyst Drivers 8.9. I also have my page file set to 2GB min / 4GB max.




  • 1
  • 2