Faiakes and Steam -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 9 years ago

Faiakes most up-to-date mod was for SoC version 1.0004. Unfortunately for me, I bought SoC on Steam, which installs version 1.0005. I read that Faiakes said there will not be a mod for 1.0005. That's too bad, because it sounded great. ^_^ The problem I'm having is that as soon as I start a new game (during which I can see that Faiakes is working because of the trader's shirt and trade selections), when I try to get the first mission from the trader, it crashes to the desktop. Since there will be no official 1.0005 version, and because there is no way for me to downgrade to 1.0004, does anyone know what causes this problem? I'd love to be able to fix it myself, if I knew more about it. (Of course, there may be even more problems later, I can't even get out of the first room). It's been almost a year since SirJager's Steam+Faiakes post; has anyone gotten these two crazy kids working together yet?




Johnreaper

I don't spend enough time here

50 XP

26th December 2008

0 Uploads

15 Posts

0 Threads

#2 9 years ago

i know there is a way to Get it working you need to edit a file in the SOC location all it is is a number But i dont think if you edit it You can play steam servers Reason being is that steam is kind of finicy i had Cs on it and i got banned cause Of one huge mistake so yea i wasted 50$ for hl GOTY i have learnt that its better to by games like SOC maxpayne and others that arnt MP heavy and just install of steam Also is a lot better in my opion to be able to call THQ or who ever is in charge when some thing Really Really Fucks up But games like HL series and L4D is better to have steam seeing as they are made/suported by vaulve




Guest

I didn't make it!

0 XP

 
#3 9 years ago

What number? Where?




Abandonator

Darth Taxi

50 XP

15th April 2008

0 Uploads

9,500 Posts

0 Threads

#4 9 years ago

I think there's a downpatching program on stalker filefront, you can try wether it works for steam I also have stalker on steam, but I play OL




natasha8384

:)

50 XP

14th May 2007

0 Uploads

140 Posts

0 Threads

#5 9 years ago
q00u;4744934What number? Where?

You need to change the server version in system.ltx in Faiakes 2.4.

Open system.ltx (it's in gamedata -> config) in Notepad and find the line: current_server_entity_version = 6

and change it to

current_server_entity_version = 7




Guest

I didn't make it!

0 XP

 
#6 9 years ago

@abandonator:

I couldn't find a downpatcher, but I did find this statement: "239. the steam version can't be downpatched" So I stopped looking. :(

@natasha8384:

I changed that number, and it still crashes in the same spot. I also went through Faiakes' thank-you list and updated the mods that have updates (very few, the main ones being OLmod 1.3, Raw Onion Revamp 1.05, and Show Reward 1.03 [this is the one I thought was causing the problem, since it is mission-related]). Still crashes when I click on "OK, I'll try"

I found I can press ESC and get out of the dialog at that point with the door open, but when I go to Wolf, I can't talk to him (no response from hitting 'F'). If I go back to the trader, it crashes when I talk to him again.

Super frustrating!