Sound Out of Sync -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 11 years ago

I've got a strange little issue when I modded some weapons. I modded the SGI 5K (renamed it the G3A3 and had it use the 7.62 rounds), and it works fine, but the sound is out of sync. The reload/firing sounds are all fine, but whenever I holster my weapon and bring it back up, it starts the sound for the bolt too early. It's only for that animation...any ideas?

Note that I went back and changed the ammo back to the 5.56 and it still did it.




>Omen<

Modern Warfare

50 XP

1st January 2005

0 Uploads

7,395 Posts

0 Threads

#2 11 years ago

It's probably because weapon animation is often written differently for different weapons, mainly to vary the reload time. It's common in games that the higher firepower weapons have slower reload times, just as a penalty for having that much firepower if nothing else, though often times due to the design of the weapon. Therefore as well as changing the weapon ammo and name, you may need to change something else.




natasha8384

:)

50 XP

14th May 2007

0 Uploads

140 Posts

0 Threads

#3 11 years ago

make sure you have the timing set to 0.35 for the reload sound and no timing on holster.




Guest

I didn't make it!

0 XP

 
#4 10 years ago
natasha8384;3864204make sure you have the timing set to 0.35 for the reload sound and no timing on holster.

I take it I can find the time-listings for these animations in the w_sig550.ltx file?

I found this in there, though I didn't see a timing on the holster:

snd_draw = weapons\ak74_draw snd_holster = weapons\generic_holster snd_shoot = weapons\t_sig550_shot ;test_shoot ;was ak74_shoot snd_empty = weapons\gen_empty, 0.5 snd_reload = weapons\sig550_reload, 0.7, 0.35 snd_shoot_grenade = weapons\gen_grenshoot snd_reload_grenade = weapons\gen_grenload, 1.0, 0.8 snd_switch = weapons\groza_switch, 1.0, 0.5




natasha8384

:)

50 XP

14th May 2007

0 Uploads

140 Posts

0 Threads

#5 10 years ago

South of Heaven11;3865298I take it I can find the time-listings for these animations in the w_sig550.ltx file?

I found this in there, though I didn't see a timing on the holster:

snd_draw = weapons\ak74_draw snd_holster = weapons\generic_holster snd_shoot = weapons\t_sig550_shot ;test_shoot ;was ak74_shoot snd_empty = weapons\gen_empty, 0.5 snd_reload = weapons\sig550_reload, 0.7, 0.35 snd_shoot_grenade = weapons\gen_grenshoot snd_reload_grenade = weapons\gen_grenload, 1.0, 0.8 snd_switch = weapons\groza_switch, 1.0, 0.5

These values above look OK. Have you possibly replaced the sounds themselves? -- they would have (usually) the same name as the default sounds. You could try loading the original holster sound from the extracted database (it's in db5) and putting into: gamedata -> sounds -> weapons




Guest

I didn't make it!

0 XP

 
#6 10 years ago

Hrmm...I haven't messed with any of the original sound files...but I'll go ahead and rewrite the sound files I got now with the original ones...if that doesn't work, oh well. Thanks for the help!