Weird, aggravating problem working with DDS inventory file -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 11 years ago

Hi, I hope someone can help me.

I am using the nVidia plugin for Photoshop. I went to edit the ui_icon_equipment.dds file in the gamedata\textures\ui directory.

As a test, I opened the dds file in photoshop without a problem. I did a little copying and pasting and added a weapon. Here's the jpeg of the inventory image after I edited:

ImageShack - Hosting :: uiiconequipmentsx5.jpg

If you look at the bottom of the second column, below the upgraded mp5 submachinegun, you can see that I merely copied the SVU rifle's icon and added a green arrow box to it -- just a basic weapon addition.

To test it, I modified one of the weapon .ltx files to have the following coordinates:

inv_grid_width = 5 inv_grid_height = 2;1 inv_grid_x = 5 inv_grid_y = 35

Which should at least be close enough to catch a corner of the new icon. (The upgraded mp5 submachinegun above it has [5, 33] for the x, y coordinates.) I also tried using 34 for the y coordinate.

Here's the problem: when I go into the game, the inventory slot for that item is completely blank; there is no icon at all, just black space.

As a test, I tried messing with one of the existing items by pasting several green arrow boxes over the weapon icon. The boxes showed up in the game, although with a graphical glitch on one of the boxes.

When I save as DDS in Photoshop, I use the settings:

DXT5 ARGB 8 bpp | interpolated alpha 2D Texture "No mipmaps" is selected

As far as I know, I am going through the appropriate steps, but in game, the icon is not where it should be.

This is too weird. Any help would be greatly, greatly appreciated, as I am working on a mod, and have some compelling ideas. But I am discouraged by this inability to add items to the inventory DDS image.




Guest

I didn't make it!

0 XP

 
#2 11 years ago

Sorry for the dreaded Double Post, :mad: Please, moderators, feel free to combine it as an edit, but after my 30 minutes were up I was unable to edit or delete my own post, so....

After working on this for awhile, I realize that it is an issue with the alpha channel masking. You would think Photoshop would have an easy way to copy and paste sections of a mask, it is 2007 after all. Good grief.

Anyway, what it amounts to is a messy problem. Now I know why so many mods have new weapons with the same old generic, inappropriate representations of the new weapons files. (Weapons with fixed silencers or scopes or nade launchers which are not all apparent in the inventory slot, etc.)

Anybody know a way to work around this? Without getting all sloppy? It's a real fly in the ointment for S.T.A.L.K.E.R. modders.

Again, sorry for the DP :mad: -- I know how you moderators hate that. Maybe lift the 30-minute limit if there are no replies. There's a thought. But I felt the topic was worth elaborating on. It's a legit issue that is not satisfactorily explained in any of the modding tutorials I have read for this game.