MODELS, in editor ok, in game black/white? -1 reply

Please wait...

SPY

SP-MAPPING!

50 XP

21st April 2003

0 Uploads

391 Posts

0 Threads

#1 15 years ago

àgain a question of me about models;

some models do look okee in the editor, (gtk 1.2.13) the colors are right. but when i play the map i see that some models still do look okee, but other ar now black and white, like if the game could find the texture for coloring the model, because the shape does look okee.

who does know the answer??

leon.




LeTHaL BaNaNa

pro

50 XP

10th May 2003

0 Uploads

1,844 Posts

0 Threads

#2 15 years ago

i know :P

use model_static, fixes most of these problems and if that doesn't work, then there was another way of fixing it, but it was in marko's forum but it's down now (GRRRRR) :(

but i think making it model_static will fix it (spawnflags 2 doesn't work on model_statics)




SPY

SP-MAPPING!

50 XP

21st April 2003

0 Uploads

391 Posts

0 Threads

#3 15 years ago

thanks banana for the quick reply,

it has to do some with an swimmingpool in the garden from a big landhouse. the pool chairs are black/white, the pooltable is okee, and a sunclock is bl/wh/

thanks, try it direct! leon




SPY

SP-MAPPING!

50 XP

21st April 2003

0 Uploads

391 Posts

0 Threads

#4 15 years ago

fantastic!!

modelas static does the trick!!

i'm glas because otherwise my hole nice pool scenery would be gone, because what should i put on a terras by a swimmingpool other than chairs.

thanks, leon




LeTHaL BaNaNa

pro

50 XP

10th May 2003

0 Uploads

1,844 Posts

0 Threads

#5 15 years ago

lol, making a finca style map or something? pool sounds nice :D




fraco

I'm too cool to Post

50 XP

8th July 2003

0 Uploads

7 Posts

0 Threads

#6 15 years ago

hey Lethal how's life m8,

anywayz,

what i want to add. RTFM -> really guys, there is this Raven document on MP mapping that comes with the SDK (under docs). I don't have it right here, but:

it says to preferably use misc_models, because model_static is a real entity thing and will add to the network traffic. It is not good practice to use it. The document also describes the right way to fix the misc_models without having to revert to a model_static. It's slightly more complex, but you will feel better after a job well done.

fraco




LeTHaL BaNaNa

pro

50 XP

10th May 2003

0 Uploads

1,844 Posts

0 Threads

#7 15 years ago

hey fraco :D we missed you on marko's forum :o glad you're back though :P




SPY

SP-MAPPING!

50 XP

21st April 2003

0 Uploads

391 Posts

0 Threads

#8 15 years ago

when i understand it right is what your saying concerns the sdk editor, i'm building now on the gtk 1.2.13.

puting models in a map looks very easy, but there are a lot of things to think about.

i did read somewhere that when you have to use a cl;ip brush(wood, stone, etc) to fill up a model so it is solid, you have to make the clipbrush so that it doesn't make contact with the ground and walls, (the brush should be 1 WU above and away from it, it should bring down otherwise the fps. i don't know if this is true, i did reed it on modsonline forum, and that's all sdk talk, but still, does this also concerns gtk?

leon




LeTHaL BaNaNa

pro

50 XP

10th May 2003

0 Uploads

1,844 Posts

0 Threads

#9 15 years ago

yeah, model_Statics you'll have to fill up with clip and shootable brushes

misc_models are calculated as a part of the map, like a normal brush and therefor add to the size of the bsp, model_statics are loaded into the game when it it launched, make the bsp smaller, but increase network traffic as fraco said :D