Problems with making maps. Help please! -1 reply

Please wait...

Yamakasi

I'm too cool to Post

50 XP

5th September 2002

0 Uploads

8 Posts

0 Threads

#1 16 years ago

Hi all!

I'm new to makeing SOFII maps, but I learn very quickly!

I have 2 problems for the moment. I hope someone could help.

1. Ladders

I'm trying to make a ladder. I followed a guide at www.gdconnect.com and it doesn't work completely. I'm using GTKRadian 1.2.10, I create my ladder brush (just the texture), next to it, I create the brush with the "Wood_Ladder" Tool Texture, then I select it, and add the triger trigger_ladder to the brush. I save, compile and load my game. When I go in the game, I don't see the trigger nor the "wood_ladder" entiy/brush. I just see the ladder texture like I should. When I step inside the entity which should make me climb the ladder. NOTHING happens! :( I'm not climbing any ladders nothing :(

2. Textures

When I apply a texture to a wall or what not in the game, in the 3D pane it shows up perfectly. Everything is fine. Then I load my game... uh oh.. The texture is reapeted like 100 times on the wall in tiny squares... what am I doing wrong?

I hope you guys can help me!! Thanks!!

- Yamakasi




KB_GUERILLA FARMER

Slightly cooler than a n00b

50 XP

12th August 2002

0 Uploads

44 Posts

0 Threads

#2 16 years ago

deselect all brushes b4 making the entity ladder trigger :) make a new brush w/entity trgger and fit it over the tool texture. then in the entity window enter angles then 0 90 0 hope it helps asfor textures as far as i know they have a predetermined size. for a wall you need to use a wall type texture. putting a poster as your wall will make many many posters.




Yamakasi

I'm too cool to Post

50 XP

5th September 2002

0 Uploads

8 Posts

0 Threads

#3 16 years ago

Hi,

Thanks for the help but it's still not working! :(

I wish someone could send me their copy of Radiant. I'm sure it's mine that's fucked up or something.

Here's what I do, step by step and it doesn't work.

1. I create a big brush for a room. I give it a height and width then I hollow it out. I de-select it.

2. I create the entity info -> player_deathmatch (I load the map in Multiplayer). I de-select it.

3. I create a light entity, place it at the right place then I de-select it.

Next comes the ladder part. Here are 2 ways that I tried doing it and the result it gives me.

1. I load the tools textures. I choose _ladder_wood. I create my brush with it and I de-select it. I then create another brush over the one I just created. While it's still selected, I open the entities, choose trigger -> trigger_ladder. I deselect. I re-select (making sure I have the entity) and I press N for the Entities Properties. In the Key area, I type in Angles and I press the 90 degree button. I press N again to remove the screen, de-select the brush, save and compile.

When I load my map, I'll go where I put the ladder and what I'll see it a box that's black and white with some white lines on it. Kind of like a black and white grid. I can't go through it nothing.

The second thing I tried is after creating the light and all that. I choose the _ladder_wood tool texture. Create my brush with it. WHILE it's selected, I choose trigger -> trigger_ladder. I unselect, save, compile. When I run the game, the brush/entity I just created will be invisible, but when I'm in the brush (in the game), nothing happens :(

I think something is screwed up with my Radiant. Could you point me to a URL where I can download the version you are using?

And as for the textures, the one I'm using for the walls is : cncr_wall_btm01.jpg. Yet it repeats itself everywhere. And it did that for 2 radiant's I've tried.

Thanks for all the help!




Yamakasi

I'm too cool to Post

50 XP

5th September 2002

0 Uploads

8 Posts

0 Threads

#4 16 years ago

Still having problems :(

I found something new. Usually when I made my Ladder Texture thing, the brush would remain black on the map. Somehow I managed ot make it green today... So that's a step forward.

But still doesn't work when I compile. And I cna't seem to enter ANGLES 0 90 0, it always changes it to angle 90 when I close it and reload it :(

Any suggestions?




Fragger

ε..з

50 XP

22nd April 2002

0 Uploads

6,816 Posts

0 Threads

#5 16 years ago

Don't make a big brush and hollow it, that's bad. make your room using 6 brushes - 4 walls, roof and floor. Don t use angles. Create the brush with the ladder texture and your other brush with the tools/ladder texture and that should do it. Works for me.




Yamakasi

I'm too cool to Post

50 XP

5th September 2002

0 Uploads

8 Posts

0 Threads

#6 16 years ago

But don't you have to put a trigger in there somewhere?




Fragger

ε..з

50 XP

22nd April 2002

0 Uploads

6,816 Posts

0 Threads

#7 16 years ago

No. No trigger.




Yamakasi

I'm too cool to Post

50 XP

5th September 2002

0 Uploads

8 Posts

0 Threads

#8 16 years ago

Okay, that's strange...

But oh well, I managed to fix ALL my problems! Thanks for the help, I'll explain in another post so other people can read it more :)