Hunk Data failed to allocate 1024 megs??? -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 11 years ago

Hello all,have a problem when i load sof2 now after a windows update.I know it has to do with the update cause i system restored and problem went away.Rather than just not install the update ,was trying to figure out what the problem is.Whenever i start sof2 now and the console comes up,@ the top of the console it says"Hunk data failed to allocate 1024 megs" and it stops there,will not continue loading.If anyone knows what this means and could give me a fix it would be greatly appreciated.Thanks...




Dark Saint

How many dogs are Pb'd?Maybe 2

50 XP

30th April 2004

0 Uploads

8,040 Posts

0 Threads

#2 11 years ago

Pc specs ?




Guest

I didn't make it!

0 XP

 
#3 11 years ago

Intel 3.4 lga775,nvidea 7950 gt,2 gig dual channel memory,soundblaster audigy 2 zs ,160 sata hd.More than enough to play soldier,been playing since it came out and now this update jacked me around.Hmmmm,Linux maybe?From the little bit i can find about this error,seems the game is asking for more memory than i have,but i know that aint the problem?Thanks for the input anyway,hope u can come up with something.




wee_menphis

Known as kit89

50 XP

2nd March 2004

0 Uploads

462 Posts

0 Threads

#4 11 years ago
Hmmmm,Linux maybe?

What has a windows update go to do with Linux?

It seems to me that Windows is now using more system resources than it use to. What background programs are you running?

To fix the problem go into the SoF2 directory then base/mp/ open the sof2mp.cfg and look for com_hunkmegs "1024" and replaceit with com_hunkmegs "512".

Although you still have a resource problem.




Goody. VIP Member

Former Network Admin and Former Forum Admin

98,478 XP

26th July 2005

4 Uploads

8,392 Posts

3 Threads

#5 11 years ago

assuming that the com_hunkmegs has been altered, which it shouldnt have been. set it to 192. anymore than that is not needed. and there are only a few reasons to alter it from its default 45. and that is a map or the goldrush mod. but i am not sure this is the cause of the problem. it sounds like a windows issue as it loads without the windows update using the same configs and a windows update would not alter sof2 config files. do you know the name or code of the update ? that would be helpful then we can see what it actually does and take it from there, also windows version ? xp or vista.




Guest

I didn't make it!

0 XP

 
#6 11 years ago

Hmmmm...Linux maybe?? was a statement i made about changing OS's,nothing to do with the problem @ hand.Anyway,last night i did go into the config.and saw that there had been no change to it as far as i could tell.B4 i even used a config that i had saved that i knew was good and same thing,so something else has changed besides the file.Also,last night i changed com_hunkmegs to 768 just to see what happened and it worked,but still doesnt answer the question as to what happened?I have just heard,and maybe i heard wrong,but to set com_hunkmegs to half of your system memory.Goody,I went and got the updates that were installed,here they r...... Update for Windows XP (KB927891) Windows XP Cumulative Security Update for Internet Explorer 7 for Windows XP (KB931768) Windows XP Update for Windows XP (KB930916) Windows XP Windows Malicious Software Removal Tool Also running windows XP Professional




Goody. VIP Member

Former Network Admin and Former Forum Admin

98,478 XP

26th July 2005

4 Uploads

8,392 Posts

3 Threads

#7 11 years ago

it was a common rule of thumb to say set your com hunkmegs to half your total ram. but that was when having 1 gb was rare and it was more usual to have 512. 192 is really the most needed to run anything the sof2 enginge can churn out. the 2 things that spring to mind are the latest italy map and of course goldrush. setting it higher is just taking resourse away from windows and will not enhance the game in anyway. funnily enough 2 of those updates are reliability updates. but theres nothing in there details that should cause your problem. with the exception of a reliabilty update for 3rd party drivers.




wee_menphis

Known as kit89

50 XP

2nd March 2004

0 Uploads

462 Posts

0 Threads

#8 11 years ago
Hmmmm...Linux maybe?? was a statement i made about changing OS's,nothing to do with the problem @ hand.

My mistake, never realised you were suggesting to change O/S. I'd recommend Ubuntu. :)