weapons not added -1 reply

Please wait...

guy_man

stuff

50 XP

25th February 2003

0 Uploads

18 Posts

0 Threads

#1 15 years ago

Hi, i was trying to add 2 weapons to a ship (pulse weapons if it really matters) and apparently i dont know how. could somebody please help me with the steps to adding a pulse weapon to a ship? i have attached a file that someone could look at and find out what is wrong. The things that i am trying to add are- Ablative Armour (for applying to the ATP, its not even placed) Super Disruptor, and Assault Disruptor. btw, might want to scan it for viruses because im not too sure about my computer. If u cant open this rar email me and i will send it to u.




MJAY

{UFM} Vice Admiral Lawrence

50 XP

27th November 2002

0 Uploads

57 Posts

0 Threads

#2 15 years ago

Obviously, you're using the ModelPropertyEditor. If I'm not to much mistaken, parent scripts are only used when you're mission scripting...:uhm:

Anyway, based on viewing the script...I assume you're working on a Borg-Assimilated BoP.

You added disruptors...some strong and some weak, and they don't work. You might want to double, triple, quadrople-check your weapon scripts. Make sure it's correctly typed.

Stop using a parent script and just make a brand new script. (Unless you're scripting a mission of course.);)

I also couldn't help but notice where your ModelPropertyEditor has saved the file you modded.

The very first line in your file, was completely different from the norm.

That's usually suppose to be C:/Program Files/Activision/Bridge Commander/scripts/ships/Hardpoints

Not that other thing that you have there...

What's my point? Point is...are you saving over the previous file you wish to change. You installed the disruptors, but after you saved, did you replace the other file with the one you have now?

And usually you don't use a parent script to install a new weapon, all you have to do is go to MPE's Template List. Are you doing that?:puzzled:

Also. You have to change the weapon script to the projectile you wish to be fired(hell with MPE you could use Quantum Torpedoes as disruptors!!).

Also don't forget to click on the button "Add Property" in the MPE menu. You must attach your new weapon before you can use it.

Other than the stuff I mentioned, I think the parent script stuff is what's getting in your way. Turn it off and you should be fine.

As for your Ablative Armour, I think it's a bug everybody that has ATP has, because mine doesn't work either. So don't worry about the armor too much.

Damn, I'm sleepy...:sleep: I hope I made sense...:confused: :sleep:




guy_man

stuff

50 XP

25th February 2003

0 Uploads

18 Posts

0 Threads

#3 15 years ago

ok i actually was modifying Quantum's D7. i found it somewhere on bcfiles. and no, really, that path u saw IS my game path. Dont ask why! also, i am not sure about the weapon icon things. all i really know about adding weapons is stuff i read in the SDK readme! i just started modding a week ago. i kinda almost expected to screw up! and, all the other modified things (reinforced hull, borg cutter beam) I modified from the original. if u want i can post the original hp file i didnt mess wth.