Adding a new race to multiplayer -1 reply

Please wait...

vonfrank

...waiting for new ships...

50 XP

17th September 2007

0 Uploads

134 Posts

0 Threads

#1 8 years ago

I have added the Star Wars Empire as a race to Armada 2 and it works completely fine in single player, however when I try to select them in a LAN game the game won't let me choose them in the race selection list. It appears on the list but when i click on it, it just makes me be federation.

I know it is possible to add new races to multiplayer, I have the ultimate dominion mod and the maker of that did it.

So i need a little help here.




pepperman

Cloaked in the Neutral Zone

50 XP

5th February 2004

0 Uploads

742 Posts

0 Threads

#2 8 years ago

Do all players in the LAN have it installed?




vonfrank

...waiting for new ships...

50 XP

17th September 2007

0 Uploads

134 Posts

0 Threads

#3 8 years ago

yes, the same exact copy of the game




Freyr VIP Member

A2Files Staff

46,876 XP

6th February 2005

11 Uploads

4,275 Posts

0 Threads

#4 8 years ago

You should have a file in your odf/others folder called "races.odf".

That will list a set of races that you have installed, I suspect that the Star Wars race you have is just calling the standard federation starting ships. You need to have a look at your race.odf (possibly empire.odf?) and see which ships it;s starting you off with. You need to adjust it so that you start off with a couple of construction ships and a starbase from your race.

More info here:- Adding a race to the game - Starbase 34 Tutorials




vonfrank

...waiting for new ships...

50 XP

17th September 2007

0 Uploads

134 Posts

0 Threads

#5 8 years ago

Yes, I know all that.

The Race is FULLY playable in instant action. The AI uses them properly and they work without any glitches when a human plays as them as well.

However when I am setting up a LAN game with my laptop (which has the EXACT same version of the game) I can see the empire on the race selection list and I can click on it, but every time i click on it, it just puts me as the federation instead.

that's the problem




Freyr VIP Member

A2Files Staff

46,876 XP

6th February 2005

11 Uploads

4,275 Posts

0 Threads

#6 8 years ago

Which map are you using? If it's not one of the defualt maps (warzone etc.) then are you using a map with map units? Your ODF settings can be overridden by certain maps.




vonfrank

...waiting for new ships...

50 XP

17th September 2007

0 Uploads

134 Posts

0 Threads

#7 8 years ago

It's a map that I made but it has no map units. it's just an instant action map