Adding new weaponry in ODF = no effect -1 reply

Please wait...

Hyronymus

AKA Captain Kirk76

50 XP

16th November 2006

0 Uploads

37 Posts

0 Threads

#1 9 years ago

Hi there, i'm working on a project to spec up default vanilla armada 2 to the specs should be, if we went by the books. Anyway, I'm currently trying to edit ODFs to begin with, and it works, apart from the added weaponry never actually do anything in game.

I'm basically copying the previous weaponry file info, and even that doesn't work. (tried incrementing the weapon(x) = too, as that seemed the obvious flaw)

Any suggestions I might be doing wrong?

Other things I have tried:

Using editors to do it I have removed the read-only properties, so it is saving the files




Guest

I didn't make it!

0 XP

 
#2 9 years ago

Are you editing the weapons or the ship ODFs? Could you please post a copy of one of the ODFs? This way someone can see what should be adjusted or corrected. If you are editing the ship ODFs for weapons, the weapon number and the weaponHardpoint number have to match, otherwise the weapon will not work. I have had similar problems. Weapon numbers have to be sequential as well. Some examples of common mistakes I've made follow.

This is by far my most common one. The weapon number and hardPoint number are mismatched. weapon1 = "ffphas" weaponHardpoints1 = "hp05" "hp06" "hp07" weapon2 = "ffphas" weaponHardpoints1 = "hp08" "hp09" "hp010"

This one is the next most common, especially when I am in a hurry. The weapon numbers are not sequential.

weapon1 = "ffphas" weaponHardpoints1 = "hp05" "hp06" "hp07" weapon3= "ffphas" weaponHardpoints3 = "hp08" "hp09" "hp10"

Sometimes, two different weapons are set up to use the same hardpoints on a model. If two weapons are using the same set of hardPoints, one or both may not work. The most obvious example of this is the stock Akira ODF. It would look something like this.

weapon1 = "ffphas" weaponHardpoints1 = "hp05" "hp06" "hp07" weapon2= "ffphot" weaponHardpoints2 = "hp05" "hp06" "hp07"

I have also upon occasion placed a hardPoint number in an ODF which did not exist on the model. Since the hardPoint isn't on the model, the game should ignore or fail to use any weapon which lists it. This does not always hold true, however. I have tractor beams mounted on most of my Fed ships. Some of them will use hardPoints which are not on the model and some of them will not. I have no idea why either.

If it is a special weapon being added to a ship or station it must be listed as available and useable in the appropriate techtree file. Techtree files are generally set up to exclude things which cannot be used. Which is exactly backwards from how the ODF files are set up.

I hope this helps you out.




Hyronymus

AKA Captain Kirk76

50 XP

16th November 2006

0 Uploads

37 Posts

0 Threads

#3 9 years ago

That solved my issues, it'd appear the offending file wasn't fully sequential with numbering.




Guest

I didn't make it!

0 XP

 
#4 9 years ago

Good to hear I was able to help. You're welcome.