Advanced Construction Ship -1 reply

Please wait...

undedavenger

Modding and equality for all.

50 XP

20th January 2008

0 Uploads

229 Posts

0 Threads

#1 9 years ago

Okay, so to build another level of sensor arrays, turrets, and a third shipyard for advanced designs, I added the advanced construction ship. Very nice, btw. Made a new string of ship, class, and physics ODFs, so that the original Construction ship stays the same, but the new one has warp drive. All worked great.

However, I am trying to add a phaser bank onto it, kind of like the Klingon construction ship. I added the weapons to the ship odf, added the "can attack" toggled on to to the class odf. Got the attack button to appear in the command menu, but still no phasers.

Any ideas what could be causing this? I went over the Big Book of Modding over and over, and I'm missing something!




Dan1025

Adopt, adapt, improve

50 XP

24th February 2007

0 Uploads

1,454 Posts

0 Threads

#2 9 years ago

Try adding "combat = 1" to the ships odf file.




undedavenger

Modding and equality for all.

50 XP

20th January 2008

0 Uploads

229 Posts

0 Threads

#3 9 years ago

Already did that. Wonder if the Klingon Const ship shares similar hardpoints? Hmmm.




stanny

I like cheese

50 XP

8th May 2004

0 Uploads

115 Posts

0 Threads

#4 9 years ago

If you think hardpoints are a problem set the phaser to HP01.




exodus_499

... soon to be "reconditioned"

50 XP

16th April 2007

0 Uploads

263 Posts

0 Threads

#5 9 years ago

Maybe post some files? Then, if I feel like it, I can read through just for fun. :D But seriously - you never know, someone might find a mistake you've missed.




pepperman

Cloaked in the Neutral Zone

50 XP

5th February 2004

0 Uploads

742 Posts

0 Threads

#6 9 years ago

If you want you can use this one...its was for A1 but could be adapted easily enough




undedavenger

Modding and equality for all.

50 XP

20th January 2008

0 Uploads

229 Posts

0 Threads

#7 9 years ago

Nah, I must have made an error editing the odf somewhere. I looked over and over and could not find one. Anyway, I just copied the Klingon one, renamed it, and corrected the hardpoints. Works okay now. Only problem I have now, though, is that my adv construction ships rush into battle everytime a cube comes within a million miles of it. lol

Thanks for all the help, I think I just goofed writing the odf or something.