Alpha problems with ms3d -1 reply

Please wait...

Adm_Stacks

Captain of USS Terrible

50 XP

28th October 2003

0 Uploads

127 Posts

0 Threads

#1 11 years ago

Does anyone know what causes Milkshape not show a grey texture with only the alpha channel showing?? And more importantly, how to fix it?




AdmarilRyan

I'm not crazy... Not always

50 XP

16th May 2005

0 Uploads

753 Posts

0 Threads

#2 11 years ago

The newer versions of milkshape 3d unfortunatly have problems displaying textures with alpha channels. i'd recommend removing the alpha channels from the textures while you doing model work (but back up the alpha channel textures) and once your totally done add the alpha channel textures in.




Ultimate_Dragon

Expert Forger and Machinimator

50 XP

3rd November 2005

0 Uploads

277 Posts

0 Threads

#3 11 years ago

I recommend DXTbmp for this problem as I have it all the time. Just resave all your textures as 24 bit bmps then resave those as targas in DXTbmp and your problem should be solved.




Chiletrek

Warriors from Fluidic Space

50 XP

8th August 2004

0 Uploads

682 Posts

0 Threads

#4 11 years ago

Hello: Another solution may be this one. In newer version of Milkshape, there is an option in the tools menu named "Assimsift Lightmap Flip tool", that tool will make your TGAs into 2 new files, a BMP (normla texture) and a BMP (that shows the alpha channel) just like in ships of the SFC games, that way you can work normally, but before you export apply the lightmap flip tool again to recover the TGAs. I hope this can help you too :)




Avon

Ageing Rapidly

50 XP

27th October 2006

0 Uploads

483 Posts

0 Threads

#5 11 years ago

I have this problem all the time. I usually do what Ryan suggested, but I will definately try Chiletrek's solution. Sounds like a good tip :nodding:




AdmarilRyan

I'm not crazy... Not always

50 XP

16th May 2005

0 Uploads

753 Posts

0 Threads

#6 11 years ago
Chiletrek;3684803Hello: Another solution may be this one. In newer version of Milkshape, there is an option in the tools menu named "Assimsift Lightmap Flip tool", that tool will make your TGAs into 2 new files, a BMP (normla texture) and a BMP (that shows the alpha channel) just like in ships of the SFC games, that way you can work normally, but before you export apply the lightmap flip tool again to recover the TGAs. I hope this can help you too :)

Whenever I try that it just simply doesn't work, I don't get why, but then I haven't put much effort into trying, again it takes about 10 seconds per texture to open it, remove the alpha channel and save a copy.




Chiletrek

Warriors from Fluidic Space

50 XP

8th August 2004

0 Uploads

682 Posts

0 Threads

#7 11 years ago

Hello: Your solution is great Ryan, and I heard that from other modders too, but why try the tip I gave?, because that saves time avoiding you to have to make the entire alpha channel again (unless you have a backup-ed texture file hidden elsewhere :p ). Well, the best is to try different things and stick with the one that works for you, right? what I hope is that Adm_Stacks can solve the problem and keep on modding :D




Majestic-MSFC

Majestic is thy Name!

50 XP

2nd April 2006

0 Uploads

2,152 Posts

0 Threads

#8 11 years ago

When I work with alphas, I do Ryans little trick, its simple and it works. ;)




Adm_Stacks

Captain of USS Terrible

50 XP

28th October 2003

0 Uploads

127 Posts

0 Threads

#9 11 years ago

Thanks guys, I'll try them all.