Changing race icons ? -1 reply

  • 1
  • 2

Please wait...

Riser

It's Stargate or NOTHING!!!

50 XP

22nd November 2005

0 Uploads

72 Posts

0 Threads

#1 11 years ago

Think im on the right track but cant get it to work. [ATTACH]52303[/ATTACH] Within gui_goauld.spr right at the bottom you can tell the the race icon what image to look at and the grid ref. I have created a new race and im trying to add there icon but when i put everything in place i just get a blank area where the icon should be. I have even tried to change the stock icons but it still shows the orignal ones. Any ideas ?




STGamer2003

The forums staffers think I'm Cool

50 XP

11th April 2003

0 Uploads

176 Posts

0 Threads

#2 11 years ago

Email ME - I can tell you: [email]zion2001@optonline.net[/email]




Flash525

The Carbon Comrade

50 XP

13th July 2004

0 Uploads

15,103 Posts

0 Threads

#3 11 years ago

You don't wish to share your knowledge? :( Which race Icions do you mean anyway? There are several. The ones that appear in-game (when you select a ship / station) it'll come up in the GUI, there are also the ones afterwards in the Admirals Log. I think there are others too...




Majestic-MSFC

Majestic is thy Name!

50 XP

1st April 2006

0 Uploads

2,152 Posts

0 Threads

#4 11 years ago

I create a 64x64 tga file with the logo in it and have the following:

Gui_global.spr

# Race icons @reference=256 federation_icon allrace 0 0 84 84 borg_icon allrace 84 84 84 84 romulan_icon allrace 168 0 84 84 species8472_icon allrace 168 84 84 84

@reference=64 cardassian_icon lc 0 0 64 64 ea_icon logo-ea 0 0 64 64 ge_icon li 0 0 64 64 klingon_icon lsc 0 0 64 64 pk_icon lp 0 0 64 64 tauri_icon lt 0 0 64 64




Riser

It's Stargate or NOTHING!!!

50 XP

22nd November 2005

0 Uploads

72 Posts

0 Threads

#5 11 years ago

I'm trying to change the Gui race icons like Majest has above. Cheers i'll give that a try. Edit: O.K. Cheers for that, it works :) Next problem: [ATTACH]52305[/ATTACH] Im getting a black box around my icon, any ideas on how to stop it ?




STGamer2003

The forums staffers think I'm Cool

50 XP

11th April 2003

0 Uploads

176 Posts

0 Threads

#6 11 years ago

I can share my knowledge, but needs to know more what he is talking about. I have assumptions, but don't want to give wrong info.




Riser

It's Stargate or NOTHING!!!

50 XP

22nd November 2005

0 Uploads

72 Posts

0 Threads

#7 11 years ago

I am getting a black area/box around my icons but the stock ones do not do this.




Flash525

The Carbon Comrade

50 XP

13th July 2004

0 Uploads

15,103 Posts

0 Threads

#8 11 years ago

My guess to your next problem would be that the stock ones have a transparent background. You'll need to edit the texture file(s) and give them a transparent background in order for them to be "see-through".




Riser

It's Stargate or NOTHING!!!

50 XP

22nd November 2005

0 Uploads

72 Posts

0 Threads

#9 11 years ago

Cheers guys for your help. Am trying to find a tut online for paint shop pro 9 about alpha channels as i have never done this before. One question, why have i not had to do this with any other gfx within the game ? Everything else that was black has never showed up.




elevatormusic

slouching toward nirvana

50 XP

18th July 2006

0 Uploads

736 Posts

0 Threads

#10 11 years ago

I don't know about PSP9... but I'm running PSP7 and to add an alpha channel, do the following: All of this refers to the 'Selections' menu. Since it's white on black, select all and then set the transparent color to black... this should leave just the white selected. Go under selections, 'save selection to alpha channel.' It should be that simple.




  • 1
  • 2