Help with Armada1 research facility -1 reply

Please wait...

joker2561

The Internet ends at GF

50 XP

19th November 2010

0 Uploads

117 Posts

0 Threads

#1 8 years ago

Ok here's the deal. I'm replacing all the stock models in armada 1 with newer, cleaner, and better looking models. I ran into a problem when trying to add a new research facility. I installed for instance the jupitor station to be the new research facility to replace the stock one. I modified the odf file to make sure the game recognized where the pod's were located on the sod. The game crashed the instant I wanted to research something.

Has anyone else encountered this problem when trying to replace the research facility with something new? Anyone know how to fix this?




k_merse

Evolution

50 XP

30th September 2007

0 Uploads

637 Posts

0 Threads

#2 8 years ago

You mean Jupiter station ;) This is a typical problem for replacing a research station, however, sometimes it's tricky to fix because it can be caused by different things. The most likely one is that you messed up something with the hardpoints Recheck them, maybe you set up wrong hardpoints for the pods. it coan cause a CTD on starting a research.




joker2561

The Internet ends at GF

50 XP

19th November 2010

0 Uploads

117 Posts

0 Threads

#3 8 years ago
k_merse;5429536You mean Jupiter station ;) This is a typical problem for replacing a research station, however, sometimes it's tricky to fix because it can be caused by different things. The most likely one is that you messed up something with the hardpoints Recheck them, maybe you set up wrong hardpoints for the pods. it coan cause a CTD on starting a research.

I'm gonna try to see what I can do, but willing to hear more suggestions. I might have to just not use the stock pods and make something new or borrow from another mod and rewrite the tech tree, which I'm not excited about doing.




k_merse

Evolution

50 XP

30th September 2007

0 Uploads

637 Posts

0 Threads

#4 8 years ago

If a game crashes o construction, it usually means that the problem is in either the ODF which is going to be constructed, or in the ODF which construcs. As the game didn't crashed when you built the station itself, the problem must be in the pod ODF or in the construction hardopints. At least in most of the cases.




joker2561

The Internet ends at GF

50 XP

19th November 2010

0 Uploads

117 Posts

0 Threads

#5 8 years ago

I have no idea what to look for, cause the pod hardpoints are valid in the jupitor station odf file.




k_merse

Evolution

50 XP

30th September 2007

0 Uploads

637 Posts

0 Threads

#6 8 years ago

Then I have two suggestions: 1. Maybe the HPs you choosed are too close to the model and the pods ould be partly built within the station. This is a very rare reason for CTD, but I saw that happening already, so give it a try. 2. Check the pod ODFs. If you want to build a lvl3 upgrade pod before the lvl2 was built, it could cause CTD.

But I still think that there is something about the hardpoints. If theseabove don't work, post the station odf (in your response) and the SOD (the file itself), maybe we could find the problem. BTW, did you change anything in the pods' ODF?




joker2561

The Internet ends at GF

50 XP

19th November 2010

0 Uploads

117 Posts

0 Threads

#7 8 years ago

k_merse;5430639Then I have two suggestions: 1. Maybe the HPs you choosed are too close to the model and the pods ould be partly built within the station. This is a very rare reason for CTD, but I saw that happening already, so give it a try. 2. Check the pod ODFs. If you want to build a lvl3 upgrade pod before the lvl2 was built, it could cause CTD.

But I still think that there is something about the hardpoints. If theseabove don't work, post the station odf (in your response) and the SOD (the file itself), maybe we could find the problem. BTW, did you change anything in the pods' ODF?

I didn't change anything in the pod odfs. I actually tried a bunch of things, but my latest attempt I didn't change a thing cause the pod hardpoints follow exactly as the same as the original model in that it goes "pod01" "pod02" and etc... in the same exact sequence. so the only thing I really changed was the sod, and I've tried doing this with other races in armada as well and same effect. like changed the klingon research facitliy and got the same CTD. This is just so frustrating cause you would think it should crash.




pepperman

Cloaked in the Neutral Zone

50 XP

5th February 2004

0 Uploads

742 Posts

0 Threads

#8 8 years ago

In your first post, you mentioned changing the odf files. Could you post the file here. In your last post, you mentioned changing the sod files. What exactly did you change in the sod?




joker2561

The Internet ends at GF

50 XP

19th November 2010

0 Uploads

117 Posts

0 Threads

#9 8 years ago
pepperman;5430885In your first post, you mentioned changing the odf files. Could you post the file here. In your last post, you mentioned changing the sod files. What exactly did you change in the sod?

I didn't modify the sod, but all I modified was this in the research odf. no other odf file was modified:

#include "research.odf"

//********************************************************************** //MAIN DESIGN PARAMETERS

//Name of Ship class in Ship Display window & in edit mode & tooltip unitName = "Jupitor Facility" tooltip = "^Jupitor Facility" verboseTooltip = "Refits vessels with additional technology."

//Race which can build ship & starting race of ship race = "federation"

//Amount of time required to build ship buildTime = 65.0

//Number of officers required to build this ship officerCost = 20

//Number of crew required to build ship & Starting crew crewCost = 300

//Dilithium Cost to build dilithiumCost = 1300

//Max Shield Strength & Begining Shield Strength <1000 maxHealth = 3000

//Rate at which shield recharges (points per second... we think) shieldRate = 2.5

//********************************************************************** //Construction Parameters

podHardpoints = "pod01" "pod02" "pod03" "pod04" "pod05" "pod6" "pod7" "pod8" "pod9" buildItem0 = "fedpod5" buildItem1 = "fedpod4" buildItem2 = "fedpod2" buildItem3 = "fedpod3" buildItem4 = "fedpod1"

//**********************************************************************

//Possible Craft Names possibleCraftNames = "Brahms Center" "Daystrom Center" "Soong Center" "Cochrane Center" "Planck Center" "Ovagadro Center" "Doppler Center" "Frege Center"

//********************************************************************** //ART PARAMETERS & WEAPON NAMES

// Hardpoints to hit for various systems and other locations. enginesTargetHardpoints = "hp16" "hp18" "hp19" "hp23" lifeSupportTargetHardpoints = "hp16" "hp18" "hp19" "hp23" weaponsTargetHardpoints = "hp16" "hp18" "hp19" "hp23" shieldGeneratorTargetHardpoints = "hp16" "hp18" "hp19" "hp23" sensorsTargetHardpoints = "hp16" "hp18" "hp19" "hp23" hullTargetHardpoints = "hp10" "hp11" "hp12" "hp13" "hp14" "hp15" "hp17" "hp20" "hp21" "hp22" "hp24" "hp25" "hp26" "hp27" "hp28" "hp29" "hp30" "hp31" "hp32" "hp33" "hp34" "hp35" "hp36" criticalTargetHardpoints = "hp16" "hp18" "hp19" "hp23"

//********************************************************************** //********************************************************************** //AI system parameters //These parameters influence how the AI evaluates and compares craft.

//The normalized intrinsic value of a target. High value craft make good //attack targets. (0.0=lowest value, 1.0=highest value) intrinsicValue = 1.00f

//**********************************************************************

//********************************************************************** //MESSAGE & SOUND PARAMETERS

eventSelect = "ResearchStationSelect" eventAcknowledge = "ResearchStationAcknowledge" eventDecommission = "ResearchStationDecommission"

//**********************************************************************

//********************************************************************** //KEYMAP LABEL keymapLabel = "research_station"

ScaleSOD = 2.0




k_merse

Evolution

50 XP

30th September 2007

0 Uploads

637 Posts

0 Threads

#10 8 years ago

Error 1: JupitEr Facility. Because it's orbiting Jupiter.

Error 2: I'm 90% sure now that there IS an error in hardpointing. First, because the naming of the HPs is not consequent. "pod01-05", but "pod6-9". No modeler makes such a mistake. It's also strange that I didn't met any model so far which would use "podx" for hardpoint names. I think you didn't edit the hardpoints, or didn't edit them properly. Please post the SOD file to take a look, or at least tell me, whose Jupiter model you use.