Hierachy question -1 reply

Please wait...

Aelita

ZZZZZzzzzz

50 XP

4th January 2006

0 Uploads

174 Posts

0 Threads

#1 9 years ago
I'm hardpointing Majestic's Saladin as practice. The problem is when I start hardpointing blinkers, they appear in almost random spots. I'm using Milkshape, and I'm attaching it to h_lights through h_root through h_scene root. Any suggestions.



Majestic-MSFC

Majestic is thy Name!

50 XP

2nd April 2006

0 Uploads

2,152 Posts

0 Threads

#2 9 years ago

Is your mesh (m_groupname) and h_root/h_scene root nodes/joints centred on the model. Meaning are they lined up with the axis (yellow, light blue and purple) thingy?

If not that could be your problem as it has happened to me before hence why I now have a standard HP map in a MS3D file and I just merge it onto the model as it saves me time and hassle. ;)




Aelita

ZZZZZzzzzz

50 XP

4th January 2006

0 Uploads

174 Posts

0 Threads

#3 9 years ago

It looks like its ignoring the up/down part of the joint. I think its centering it, although the left/right, and the forward/backword works fine.




Aelita

ZZZZZzzzzz

50 XP

4th January 2006

0 Uploads

174 Posts

0 Threads

#4 9 years ago

no its putting the blinky in the same spot....




Majestic-MSFC

Majestic is thy Name!

50 XP

2nd April 2006

0 Uploads

2,152 Posts

0 Threads

#5 9 years ago

Send me your email via PM and I'll send you this afternoon a HP Map for you to merge on.




Aelita

ZZZZZzzzzz

50 XP

4th January 2006

0 Uploads

174 Posts

0 Threads

#6 9 years ago

I got it, it was cause of.... (drumroll please)

Joint rotation

Isn't that silly




Majestic-MSFC

Majestic is thy Name!

50 XP

2nd April 2006

0 Uploads

2,152 Posts

0 Threads

#7 9 years ago

So you got it fixed? If not I can write another tutorial as I did for the cheat method for you.




Aelita

ZZZZZzzzzz

50 XP

4th January 2006

0 Uploads

174 Posts

0 Threads

#8 9 years ago

yup it works.