Ship broken, need assist. -1 reply

Please wait...

peanutbutter

I want to be like the Admins

50 XP

11th May 2006

0 Uploads

228 Posts

0 Threads

#1 10 years ago

Ok, I have successfully put my ship in game, but it's in pieces, meaning it's in different parts, it's basically a big mess, one engine is here the other there, and the rest of the model upside down.

I have gone over Majorpayne's tutorial and all to check and see what i have done wrong, but i suspect this problem has something to do with the model itself, i already tried weilding/merging the model but that creates too many extra faces and messes it up even further (A2 really need's an in-depth tutorial). The model was initially one big piece but i exported it to obj format and edited it using other software for texturing and such...

Anyone have any clue to what could be causing this, and how do i fix this ? First model, first mod here, so i'm completely clueless and would appreciate any and all the help.




Guest

I didn't make it!

0 XP

 
#2 10 years ago

Is it in game as an obj or an SOD?




Avon

Ageing Rapidly

50 XP

27th October 2006

0 Uploads

483 Posts

0 Threads

#3 10 years ago

Ok, make sure your scene_root and all your mesh joints (the ones starting with m_ ) are all in the very centre of the axis (the blue and yellow lines.) It's something that's not mentioned in the tutorial. Also make sure your main hardpoints joint is in the centre too or your hardpoints will be off as well.




delta_dids

What Lies Beyond...

50 XP

9th December 2006

0 Uploads

145 Posts

0 Threads

#4 10 years ago

the mesh joints m_ have to come from the scene root right?




peanutbutter

I want to be like the Admins

50 XP

11th May 2006

0 Uploads

228 Posts

0 Threads

#5 10 years ago

Avon, you're a Genius, that fixed it. I cant' believe it was so simple and you're right, it's not mentioned in the tutorial, however, even a slight deviation from the center axis seems to severely affect the model.