Strange -1 reply

  • 1
  • 2

Please wait...

CanadianBorg

Resistance is futile, eh?

50 XP

30th July 2008

0 Uploads

503 Posts

0 Threads

#1 10 years ago

Continuing my Armada III leftovers series, I have ported another ship and a station from the A3 collection to Armada. Anyway, I have a problem: Pieces of this ship (the Romulan Akhiy'khaiell Class, intended to replace the stock Venator) are vanishing, and I don't know why. I have the mesh node (there is only one) connected properly, and it looks fine in Storm3D. I have also hooked up the alphas correctly, so that's not it. Also, it worked fine the first time I built it, but now look. I have included a screenshot. I also selected the ship to make it more apparent. Just look at the closest wing and you can see what I'm getting at. The funny thing is that it ONLY occurs on the back wings, and not anywhere else on the rest of the ship. I have also included a screen from MS3D, at roughly the same angle, as a comparison.




pepperman

Cloaked in the Neutral Zone

50 XP

5th February 2004

0 Uploads

742 Posts

0 Threads

#2 10 years ago

my guess is that somewhere in the process those faces are reversed. try selecting the offering triagles and then use the reverse vertex order and see if that fixes it. nice shipe by the way lol




CanadianBorg

Resistance is futile, eh?

50 XP

30th July 2008

0 Uploads

503 Posts

0 Threads

#3 10 years ago

That didn't do it. I tried it and nothing happened.




Ragnar

Sneaking about...

50 XP

17th April 2007

0 Uploads

951 Posts

0 Threads

#4 10 years ago

Might want to make sure that the faces aren't doubled up, that might stop the textured faces beneath showing properly.




CanadianBorg

Resistance is futile, eh?

50 XP

30th July 2008

0 Uploads

503 Posts

0 Threads

#5 10 years ago

I'm going to check the MS3D help page, there might be something there.




CanadianBorg

Resistance is futile, eh?

50 XP

30th July 2008

0 Uploads

503 Posts

0 Threads

#6 10 years ago

Here's what the MS3D help page said: Why are there holes in my model when I export my model into a game? [INDENT] The faces where the holes are, are facing inwards, they have a Clockwise Vertex Order. To correct this go back to MilkShape and right-click the perspective viewport then select Flat Shaded from the pop-up menu. All faces that are black should be selected then the action Face->Reverse Vertex Order should be performed. It is recommended that before exporting that you perform this procedure to avoid wasting time exporting models with holes in them.

Problem is, when I did that, the whole thing was white.

[/INDENT]




CanadianBorg

Resistance is futile, eh?

50 XP

30th July 2008

0 Uploads

503 Posts

0 Threads

#7 10 years ago

After examining the model, I have come to this conclusion: Sometime during poly reduction (done by apoclaydon during the project), something went wrong. I have compared the original SFC model (approx 8000 polies) with the current version (approx 4000 polies). Included is a screen demonstrating the problem. If anyone wants to take on re-reducing this model to eliminate the problem, or you have a solution, please speak up.




Bastion

Slightly cooler than a n00b

50 XP

24th August 2008

0 Uploads

41 Posts

0 Threads

#8 10 years ago

Wow, I'd like to get that ship without the rear wings if thats possible.




F/\}{I´3$

Illiterate? I'm FahreS

50 XP

24th March 2006

0 Uploads

1,230 Posts

0 Threads

#9 10 years ago

CanadianBorg;4563250Here's what the MS3D help page said: Why are there holes in my model when I export my model into a game? [INDENT] The faces where the holes are, are facing inwards, they have a Clockwise Vertex Order. To correct this go back to MilkShape and right-click the perspective viewport then select Flat Shaded from the pop-up menu. All faces that are black should be selected then the action Face->Reverse Vertex Order should be performed. It is recommended that before exporting that you perform this procedure to avoid wasting time exporting models with holes in them.

Problem is, when I did that, the whole thing was white.

[/INDENT]

Turn the emissive material color to black, or you wont see black faces.




CanadianBorg

Resistance is futile, eh?

50 XP

30th July 2008

0 Uploads

503 Posts

0 Threads

#10 10 years ago

Bastion;4563662Wow, I'd like to get that ship without the rear wings if thats possible.[/quote]

Sorry, if I did that there would be gaping holes in the mesh.

[quote=F/\}{I´3$;4563848]Turn the emissive material color to black, or you wont see black faces.

OK, I'll try that. Thanks FahreS.




  • 1
  • 2