Texture question -1 reply

  • 1
  • 2

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

I'm trying to convert a ship and part of the texture is showing up black on the model no mater what I do. Does any one know what is going on?




Achilles

I stole fire from the lighter!

50 XP

13th January 2003

0 Uploads

1,596 Posts

0 Threads

#2 10 years ago

I take it this is before you export, it should work fine regardless. It's usually a result of psp not saving it just right for me, which is why I resave everything in photoshop... if this aint it a little more info then buddy :p




F/\}{I´3$

Illiterate? I'm FahreS

50 XP

24th March 2006

0 Uploads

1,230 Posts

0 Threads

#3 10 years ago

yeah try it ingame, it should work. Its probably because youve activated "draw backfaces".




Guest

I didn't make it!

0 XP

 
#4 10 years ago

Well its only that one section the rest of the ship shows it fine. I'll try it in game and see if it works right. The model started out as a wavefront object fited for Homeworld 2. Could this have something to do with it?




Guest

I didn't make it!

0 XP

 
#5 10 years ago

Heres a pic of the problem.




CanadianBorg

Resistance is futile, eh?

50 XP

30th July 2008

0 Uploads

503 Posts

0 Threads

#6 10 years ago

If you're using MS3D, go into the "Materials" tab. Select the material applied to those sections. Now, change the diffuse value to 255,255,255. That should do it. The backfaces thing would actually make sections of the mesh disappear when looked at from the top.




Guest

I didn't make it!

0 XP

 
#7 10 years ago

The diffuse already is 255,255,255.:(




Icewolf132

Only Slightly Insane

50 XP

1st June 2007

0 Uploads

182 Posts

0 Threads

#8 10 years ago

What might have happened is that those faces got flipped around, try selecting the faces around where the black is at on the rear struts (engines?), and if you got Milkshape then go to Face>Reverse Vertex Order...or go to whatever option flips Faces over in the program you're using. Then take a look at it in Storm3D and see if it fixed the problem, if so then do the same to the rest of the black areas. If not...uh...hit undo a few times and forget what I said >.>;




Fireball_VI

I follow teh Moo!

50 XP

6th June 2008

0 Uploads

626 Posts

0 Threads

#9 10 years ago
Achilles;4743636I take it this is before you export, it should work fine regardless. It's usually a result of psp not saving it just right for me, which is why I resave everything in photoshop... if this aint it a little more info then buddy :p[/quote] Yeesshhh, so i'm not the only one that does that? :rofl: PSP can't save those TGA's at all, but I can't use Photoshop to make textures so i'm at a loss :lol: [quote=Icewolf132;4743960]What might have happened is that those faces got flipped around, try selecting the faces around where the black is at on the rear struts (engines?), and if you got Milkshape then go to Face>Reverse Vertex Order...or go to whatever option flips Faces over in the program you're using. Then take a look at it in Storm3D and see if it fixed the problem, if so then do the same to the rest of the black areas. If not...uh...hit undo a few times and forget what I said >.>;

That may be right, looks like that in the pic. Try this out, Is there an importer for max for those homeworld 2 models? If so and this doesn't work, I can always give it a whirl for ya?




Guest

I didn't make it!

0 XP

 
#10 10 years ago

That was the first thing I tried cause thats exactly what it looked lik but no joy. It would need to be a wavefront .OBJ impoter, their not in the Homeworld model format. Can you import this format?




  • 1
  • 2