Trouble with downloaded mod -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 14 years ago

Hi all, Yes I know, newbie alert :) My prob : I downloaded the 'Sigma' mod, quite a cool vessel. I acctually get it to work, sort of, when I build it in the ship yard , it starts building normally, but when the ship is finished en should roll out of the yard, a2 quits do to an error. Does anyone know what this is and how i can correct it? Thanks in advance, crashmatrix




Major A Payne

The 6th Day

50 XP

7th August 2002

0 Uploads

2,535 Posts

0 Threads

#2 14 years ago

Check the ODF files that came with the ship. Look for things like weapons errors (incorrectly named, or possibly misspelt). Also look for inverted commas " which may be missing or extra ones which have been added. Failing that copy and paste the main ships odf into a thread reply, if you can't find the problem. Someone else might see it.




Guest

I didn't make it!

0 XP

 
#3 14 years ago

Hi all, I've been viewing the odf file, but found nothing out of the ordinary. Here's the odf [indent]// Begin main properties unitName = "Wells Class" tooltip = "Wells Class - Temporal Stasis Field" race = "federation" buildTime = 30.0 officerCost = 20 crewCost = 250 dilithiumCost = 3000 maxHealth = 2950 shieldRate = 40.7 maxSpecialEnergy = 60000 specialEnergyRate = 50 attackPower = 1.00f intrinsicValue = 0.75f shieldGeneratorHitPoints = 1000 enginesHitPoints = 1000 weaponsHitPoints = 1000 lifeSupportHitPoints = 1000 sensorsHitPoints = 1000 shipclass = "destroyer" enginesHitPercent = 5.0f lifeSupportHitPercent = 8.5f weaponsHitPercent = 5.0f shieldGeneratorHitPercent = 8.0f sensorsHitPercent = 8.0f crewHitPercent = 8.5f hullHitPercent = 57.0f // End main properties // Begin weapons weapon1 = "bm4phas" weaponHardpoints1 = "hp01" weapon2 = "bm4phas" weaponHardpoints2 = "hp02" weapon3 = "bm4phas" weaponHardpoints3 = "hp03" weapon4 = "bm4phas" weaponHardpoints4 = "hp04" weapon5 = "bm4phas" weaponHardpoints5 = "hp05" //Slipstream Drive weapon6 = "slipstream" weaponHardpoints6 = "hp04" "hp05" //Photon Torpedo weapon7 = "fdphot" weaponHardpoints7 = "hp04" "hp05" "hp01" "hp02" "hp03" // Detect Cloak weapon8 = "gdetectf" weaponHardpoints8 = "hp04" "hp05" "hp01" "hp02" "hp03" // Temporal Stasis Field weapon9 = "atemp" weaponHardPoints9 = "hp04" "hp05" "hp01" "hp02" "hp03" // Temporal Stasis Field weapon10 = "gmtunel3" weaponHardPoints10 = "hp70" // End weapons // Begin hardpoints enginesTargetHardpoints = "hp12" "hp13" lifeSupportTargetHardpoints = "hp14" "hp25" "hp26" weaponsTargetHardpoints = "hp14" "hp25" "hp26" shieldGeneratorTargetHardpoints = "hp14" "hp25" "hp26" sensorsTargetHardpoints = "hp14" "hp25" "hp26" hullTargetHardpoints = "hp14" "hp15" "hp25" "hp26" criticalTargetHardpoints = "hp12" "hp13" "hp14" "hp25" "hp26" // End hardpoints // Begin sounds eventSelect = "BraxtonSelect" eventAcknowledge = "BraxtonAcknowledgee" eventAttack = "BraxtonAttack" eventRedAlert = "BraxtonRedAlert" eventYellowAlert = "BraxtonYellowAlert" eventGreenAlert = "BraxtonGreenAlert" eventStop = "BraxtonStop" eventMove = "BraxtonMove" eventRepair = "BraxtoneRepair" eventSelfDestruct = "BraxtonDestruct" // End sounds // Begin misc properties isHero = 1 label = "Wells Class" weaponYellow = 1.0f weaponRed = 2.0f ScaleSOD = 0.8 weldingRadius = 0.25 physicsFile = "scruise3phys.odf" trekPhysicsFile = "scruise3phys.odf" avoidanceClass = 3 fireball = "xfirebsm" combat = 1 alert = 1 can_sandd = 1 shipType = "C" shieldDelay = 3.0f rangeScan = 800.0f damagedScan = 125.0 enginesRepairTime = 1.0f lifeSupportRepairTime = 0.1f weaponsRepairTime = 2.0f shieldGeneratorRepairTime = 2.0f sensorsRepairTime = 3.0f enginesCrewLoss = 5.0f lifeSupportCrewLoss = 3.0f weaponsCrewLoss = 2.0f shieldGeneratorCrewLoss = 2.0f sensorsCrewLoss = 2.0f lifeSupportLoss = 2.0f classLabel = "craft" aiName = "CraftProcess" ship = 1 has_hitpoints = 1 has_crew = 1 transporter = 1 SHOW_MOVEMENT_AUTONOMY = 1 can_explore = 1 // End misc properties [/indent] Hope you can make more out of it then I can




Major A Payne

The 6th Day

50 XP

7th August 2002

0 Uploads

2,535 Posts

0 Threads

#4 14 years ago

Oh for the love of god. There are times when a modder needs to be shot!!!

Anyway, Crashmatrix. This isn't your fault in any way. Whats happened is there are missing files from the release. I downloaded it myself and went through the files (very poorly put together if you ask me, no build buttons, no references for the station it should be built from, no tech tree files). Right then. If all your doing is having trouble with getting to launch from the shipyard try removing the following from the ODF:

//Slipstream Drive weapon6 = "slipstream" weaponHardpoints6 = "hp04" "hp05"

// Temporal Stasis Field weapon9 = "atemp" weaponHardPoints9 = "hp04" "hp05" "hp01" "hp02" "hp03"

You may need to renumber the weapons accordingly so that they are in numbered order. Hopefully this should sort it out for you.




cds7318

I follow teh Moo!

50 XP

1st April 2003

0 Uploads

682 Posts

0 Threads

#5 14 years ago

Yeah i gave up on that ship too. just wasnt worth it. Taking those lines out of the file should help.

Also. I wish modders learned to write those themselfs. i hate that program and how it does the odf. They look like trash.




Guest

I didn't make it!

0 XP

 
#6 14 years ago

Hi all, Look, that's what I need, someone who acctually can help me with this junk mod. The ship itself is nice, i'll try to make it fully functional. Greetingzz, crashmatrix