Using "ReplaceWeapon" to upgrade orbital mining station -1 reply

Please wait...

Mighty442

I don't spend enough time here

50 XP

16th September 2008

0 Uploads

17 Posts

0 Threads

#1 10 years ago

So I was tried of having to defend my orbital mining station and wanted to figure out a way to upgrade them with some armament. Instead of just constructing a whole different station I wanted to be able to have it upgrade itself. I was hoping using the Fleet Ops 1.2.5 patch's "ReplaceWeapon" command would do it but I'm having crashing problems. I've created a orbital mining station with sensor ODF and also created a special weapon for the normal orbital station to upgrade to the new station. I've also added both the new station and special weapon to the fulltech.tt and tech1.tt files. I don't know what I'm doing wrong. This is the info I have for the special weapon upgrade for the normal orbital station. //Display name for this weapon wpnName = "Orbital Station Upgrade" //tooltips tooltip = "Orbital Station Upgrade" verboseTooltip = "Upgrades your orbital mining station with a tachyon detection sensor." //Time Delay between shots - not used //shotDelay = 0.0 //Location of the button in the speed panel //buttonSlot = 3 // location of the button in the popup palette //popupSlot = 5 // Priority of button in the speed panel, this is only // used if it is non-zero. //buttonPriority = 10 //Type of border to use for this button. //0 = No border. //1 = Offensive border. //2 = Defensive border. buttonBorder = 0 // special = 1 //Programming Stuff DO NOT CHANGE classLabel = "ReplaceWeapon" //this special weapon can be assimilated by the borg tech assimilator //assimilatable = "fedpod1" replacement0Class0 = "forbital_s.odf" replacementkeepName = 1 DilithiumCost = 100 MetalCost = 100 CrewCost = 50 RequiredOfficers = 1 The button comes up on the normal orbital station for the upgrade but the second I push it the game crashes. Any help from you guys would be great. I'm hoping to be able to make several levels of upgrade for the orbital station. Starting with sensors, pulse phasers and finally torpedos. Thanks in advance.




Amateur

beginner on armada2files

50 XP

23rd April 2005

0 Uploads

398 Posts

0 Threads

#2 10 years ago

I must admit that special weapons, and coding for that matter, are not my strong point; but I'll try and help... Here's one of my replacements that i know works... //Display name for this weapon wpnName = "Galaxy Class Refit" //tooltips tooltip = "Galaxy Class Refit" verboseTooltip = "Upgrades the standard Galaxy class into the Venture variant; which has increased armour and weaponry." //Time Delay between shots - not used //shotDelay = 0.0 //Location of the button in the speed panel //buttonSlot = 3 // location of the button in the popup palette //popupSlot = 5 // Priority of button in the speed panel, this is only // used if it is non-zero. [COLOR=red]buttonPriority = 10[/COLOR] //Type of border to use for this button. //0 = No border. //1 = Offensive border. //2 = Defensive border. [COLOR=red]buttonBorder = 2[/COLOR] // special = 1 //Programming Stuff DO NOT CHANGE classLabel = "ReplaceWeapon" //this special weapon can be assimilated by the borg tech assimilator //assimilatable = "fedpod1" replacement0Class0 = "fbcruisr.odf" // Replace with Galaxy Class Refit [COLOR=red]replacementCreationType = 0[/COLOR] replacementkeepName = 1 //The name shouldn't change... [COLOR=red]replacement0Class0Position = 0,0,0[/COLOR] [COLOR=red]replacementKeepOwner = 0[/COLOR] //disabled I've highlighted in red what I think you need to include. Now it might not be this but rather a problem with the orbital station. If might not be possible for it to convert like this... Hope this helps. :)




Mighty442

I don't spend enough time here

50 XP

16th September 2008

0 Uploads

17 Posts

0 Threads

#3 10 years ago

[COLOR=black]"buttonPriority = 10" doesn't really matter for the type of button it is.[/COLOR] [COLOR=black]"buttonBorder = 2" I've tried different settings for this but the truth of the mattter is I don't need a button border since I'm using the same button for sensor upgrades from the ship upgrade research station.[/COLOR] [COLOR=black]"replacementCreationType = 0" the default setting for this is already zero.[/COLOR] [COLOR=black]"replacement0Class0Position = 0,0,0" the default for this setting is also already zero.[/COLOR] I thought those might of been the case too and I did add them into the ODF but it didn't make a difference, game would still crash. I think you might be right and it just won't work with a orbital station. I hope that's not the case though.




CanadianBorg

Resistance is futile, eh?

50 XP

30th July 2008

0 Uploads

503 Posts

0 Threads

#4 10 years ago

Are you sure you have the 1.2.5 patch installed? Because you need it for this stuff to run at all.




Ragnar

Sneaking about...

50 XP

17th April 2007

0 Uploads

951 Posts

0 Threads

#5 10 years ago

Make sure the ODF you're upgrading the station to has the correct hardpoints. Weapons that are allocated to other hardpoints that don't exist on the .SOD model will cause it to crash as soon as it tries to fire.




Mighty442

I don't spend enough time here

50 XP

16th September 2008

0 Uploads

17 Posts

0 Threads

#6 10 years ago
CanadianBorg;4613768Are you sure you have the 1.2.5 patch installed? Because you need it for this stuff to run at all.

Yes, I'm absolutely sure I'm using 1.2.5. I'm a newb but I'm not that big of a newb.




Mighty442

I don't spend enough time here

50 XP

16th September 2008

0 Uploads

17 Posts

0 Threads

#7 10 years ago
Ragnar;4613791Make sure the ODF you're upgrading the station to has the correct hardpoints. Weapons that are allocated to other hardpoints that don't exist on the .SOD model will cause it to crash as soon as it tries to fire.

Yes, I am using the correct hard points. I'm using the exact same ODF and SOD as the old federation orbital mining station. I just renamed them both appropriately. I'm using a hard point that is already listed in the ODF.