Weird things happening -1 reply

Please wait...

Fireball_VI

I follow teh Moo!

50 XP

6th June 2008

0 Uploads

626 Posts

0 Threads

#1 9 years ago

Hey guys, I know I have not posted in a while or done much in a while as I've been busy with a new job. However, last weekend (and a tiny bit this week) I have been putting together my Klinks for release.

I have encountered some WEIRD things. My first (and probably easiest to solve) problem is that I can't get my yard to be build only.

I've tried both of these:

can_repair = 0 repair_facility = 0

I also don't have a docking point specified..

Now next, I have a Research Facility with 7 pods. The first 4 pods work fine, the last 3 pods are completely misplaced. But get this, when I go into cinematic view, the pods are just fine, where they are supposed to be.... Back to normal view and the pods are messed up again.

I don't even know where to begin with this one...

Spoiler: Show

snapshot007t.jpg

Spoiler: Show

snapshot008y.jpg

Next on the list of weird. I made a very quick Orbital Mining station as the last one just didn't cut it with me. I had it as build item 5 and it would not show up. For the life of me I didn't know why, I triple checked everything. I changed it to build item 4, and build item 4 to build item 5. All of the sudden it and everything else is showing up...

But of course it doesn't want to work properly for me. When you build it, it appears the WRONG way. (IE mining beam projector is not facing the planet). As soon as construction finishes, it magically faces the right direction and orbits the planet... I have no idea how to approach is problem either, it's highly unusual.

Spoiler: Show

snapshot001gq.jpg

Spoiler: Show

snapshot002.jpg

Of course my problems don't end here. My mining station will not animate properly. I have an animation so that when a miner enters the station, the doors will close, as soon as it finishes, the doors should open again. However the animation just keeps looping over and over again. Is there anything I can do to fix this? I really don't want to eliminate the doors because they look pretty cool, and I put some cool windows on top of the mining station so you can see inside even when the doors are closed, it's kind of the whole point..

Finally last but not least, We have the Admirals Log not working.... Any time the match ends or I abort or try to go to the Admirals Log, I get a crash to desktop. I specified an icon for them and such, all ships are under the race name 'klingonTos' I really don't understand whats going on here and why things are being so weird....I would appreciate any suggestions anyone could give me.

PS - I'll release the Conny asap and I apologize for it taking so long..It's so hard to bring such a big project together. There is seriously more file than there is in the Klingon Full Race right now (mind you I only have about 5 stations and 5 ships in-game right now, at least in the "full-race" aspect)

Thanks for reading and any help you can provide :)

Cheers

edit - put repair only instead of build only




Majestic-MSFC

Majestic is thy Name!

50 XP

2nd April 2006

0 Uploads

2,152 Posts

0 Threads

#2 9 years ago

You'll need to specify a repair point and make sure you don't have the build list there or a build point.

To assist here is my odf for my Gorn repair yard from yesteryears:

Spoiler: Show

#include "station.odf"

//********************************************************************** //MAIN DESIGN PARAMETERS

//Name of Ship class in Ship Display window & in edit mode & tooltip unitName = "Repair Yard"

//tooltips tooltip = "GRN_STAT12" verboseTooltip = "GRN_STAT12_V"

//Race which can build ship & starting race of ship race = "gorn"

//Amount of time required to build ship buildTime = 120.0

//Number of officers required to build this ship officerCost = 0

//Number of crew required to build ship & Starting crew crewCost = 500

//Dilithium Cost to build dilithiumCost = 300

//Metal cost to build metalCost = 1000

//Max Shield Strength & Begining Shield Strength <1000 maxHealth = 2500

//Rate at which shield recharges (points per second... we think) shieldRate = 2.08

//Possible Craft Names possibleCraftNames = "Cestus Prime" "Bolarus Prime" "Altair Prime" "Barcon Prime" "Idran Prime" "Invernia Prime" "Ledonia Prime" "Janus Prime" "Tellar Prime"

//********************************************************************** //ART PARAMETERS & WEAPON NAMES

// Hardpoints to hit for various systems and other locations. enginesTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" lifeSupportTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" weaponsTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" shieldGeneratorTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" sensorsTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" hullTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" criticalTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09"

//**********************************************************************

//********************************************************************** //Hardpoint location for building. repairHardpoint = "build" //********************************************************************** //********************************************************************** //AI system parameters //These parameters influence how the AI evaluates and compares craft.

//The normalized intrinsic value of a target. High value craft make good //attack targets. (0.0=lowest value, 1.0=highest value) intrinsicValue = 1.00f

//**********************************************************************

//********************************************************************** //MESSAGE & SOUND PARAMETERS //**********************************************************************

eventSelect = "AdvShipyardSelect" eventAcknowledge = "AdvShipyardAcknowledge" eventDecommission = "AdvShipyardDecommission"

//********************************************************************** //PROGRAMMING PARAMETERS WHICH SHOULD NOT BE CHANGED & UNUSED PARAMETERS

//Runtime class label for instantiation of object. classLabel = "shipyard"

//********************************************************************** //KEYMAP LABEL // Obsolete, use hotkeyLabel // keymapLabel = "adv_shipyard" hotkeyLabel = "HOTKEY_F8"

//************************************************************ // Brian additions for context sensitive menus builder_ship = 1 transporter = 1 SHOW_MOVEMENT_AUTONOMY = 1 SHOW_SW_AUTONOMY = 1

// make it bigger ScaleSOD = 4.00

As for the crashing Admiral Log, I'd make sure one the BMP images for the ships are in the right format and byte rate. Easiest way is to open a stock one, paste your image over it and save it as a new image. Also they have to be 220pixels wide it doesn't matter how high but it needs to be 220 wide.

I hope some of this can help you. I haven't encountered the other issues before and rarely use animations as I can't animate with MS3D so I am unfortunately no help there.




Fireball_VI

I follow teh Moo!

50 XP

6th June 2008

0 Uploads

626 Posts

0 Threads

#3 9 years ago

Majest;5342824You'll need to specify a repair point and make sure you don't have the build list there or a build point.

To assist here is my odf for my Gorn repair yard from yesteryears:

Spoiler: Show

#include "station.odf"

//********************************************************************** //MAIN DESIGN PARAMETERS

//Name of Ship class in Ship Display window & in edit mode & tooltip unitName = "Repair Yard"

//tooltips tooltip = "GRN_STAT12" verboseTooltip = "GRN_STAT12_V"

//Race which can build ship & starting race of ship race = "gorn"

//Amount of time required to build ship buildTime = 120.0

//Number of officers required to build this ship officerCost = 0

//Number of crew required to build ship & Starting crew crewCost = 500

//Dilithium Cost to build dilithiumCost = 300

//Metal cost to build metalCost = 1000

//Max Shield Strength & Begining Shield Strength <1000 maxHealth = 2500

//Rate at which shield recharges (points per second... we think) shieldRate = 2.08

//Possible Craft Names possibleCraftNames = "Cestus Prime" "Bolarus Prime" "Altair Prime" "Barcon Prime" "Idran Prime" "Invernia Prime" "Ledonia Prime" "Janus Prime" "Tellar Prime"

//********************************************************************** //ART PARAMETERS & WEAPON NAMES

// Hardpoints to hit for various systems and other locations. enginesTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" lifeSupportTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" weaponsTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" shieldGeneratorTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" sensorsTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" hullTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09" criticalTargetHardpoints = "hp01" "hp02" "hp03" "hp04" "hp05" "hp06" "hp07" "hp08" "hp09"

//**********************************************************************

//********************************************************************** //Hardpoint location for building. repairHardpoint = "build" //********************************************************************** //********************************************************************** //AI system parameters //These parameters influence how the AI evaluates and compares craft.

//The normalized intrinsic value of a target. High value craft make good //attack targets. (0.0=lowest value, 1.0=highest value) intrinsicValue = 1.00f

//**********************************************************************

//********************************************************************** //MESSAGE & SOUND PARAMETERS //**********************************************************************

eventSelect = "AdvShipyardSelect" eventAcknowledge = "AdvShipyardAcknowledge" eventDecommission = "AdvShipyardDecommission"

//********************************************************************** //PROGRAMMING PARAMETERS WHICH SHOULD NOT BE CHANGED & UNUSED PARAMETERS

//Runtime class label for instantiation of object. classLabel = "shipyard"

//********************************************************************** //KEYMAP LABEL // Obsolete, use hotkeyLabel // keymapLabel = "adv_shipyard" hotkeyLabel = "HOTKEY_F8"

//************************************************************ // Brian additions for context sensitive menus builder_ship = 1 transporter = 1 SHOW_MOVEMENT_AUTONOMY = 1 SHOW_SW_AUTONOMY = 1

// make it bigger ScaleSOD = 4.00

As for the crashing Admiral Log, I'd make sure one the BMP images for the ships are in the right format and byte rate. Easiest way is to open a stock one, paste your image over it and save it as a new image. Also they have to be 220pixels wide it doesn't matter how high but it needs to be 220 wide.

I hope some of this can help you. I haven't encountered the other issues before and rarely use animations as I can't animate with MS3D so I am unfortunately no help there.

Thanks Majest, I apreciate it. My mistake in the above post, I meant Build only haha. But your ODF will prove to be quite useful when I design and build a repair yard for the Klinkers.

All of the images are 220 pixels wide...Even if I take all of them out it crashes...it's really weird..




Cpt.BenSisko

Battlestations!!!!

50 XP

23rd March 2004

0 Uploads

306 Posts

0 Threads

#4 9 years ago

Fireball...make sure you have all the mesh points for your models centered really well..ive experienced that in the past as well with parts of the mesh not being where its supposed to be...also animated stations don't react well to scaleSOD = xxx so that will mess up your animations if you have the stations scaled with that command..just a few tidbits ive picked up over the years...




Majestic-MSFC

Majestic is thy Name!

50 XP

2nd April 2006

0 Uploads

2,152 Posts

0 Threads

#5 9 years ago
Fireball_VI;5342877Thanks Majest, I apreciate it. My mistake in the above post, I meant Build only haha. But your ODF will prove to be quite useful when I design and build a repair yard for the Klinkers.

Well if that's the case add this to the odf:

can_repair = 0

1 = Yes, 0 = No.

It works on both ships and stations.

As for your Admiral Log problems, you've stumped me so I can't help you unfortunately. Perhaps turning the Admiral Log back to stock and try changing it slowly.




k_merse

Evolution

50 XP

1st October 2007

0 Uploads

637 Posts

0 Threads

#6 9 years ago

For the pods problem: I met this one as well. It helped, when I moved h_Scene_root exactly to 0.0.0, then it worked fine.




apoclaydon

Modding Beginner

50 XP

7th October 2006

0 Uploads

286 Posts

0 Threads

#7 9 years ago

for mining station animation i think u need to remove the animate odf code as it has an hardpointed animation switch like a construction switch cud b wrong i forgot wot i did wen animating my cardassian miningstation