Bizarre Fed AI glitch - Armada 2, v1.1 -1 reply

Please wait...

Knight-2000

Dread thinks I'm a special person

50 XP

19th March 2006

0 Uploads

338 Posts

0 Threads

#1 11 years ago

This is a weird one that if anyone can help me with, I'd much appreciate it - I've recently started a completely fresh armada (removed all the previous mods i'd added) and installed the 1.1 patch, before starting to re-apply all the mods in a much tidier fashion (until the re-install and patch, my armada game had been modded to death and had bits in that had since been removed).

I started with the Klingons, added the carrier, and a couple of Vorcha mods, as well as made Martok's Neghvar a starting ship - I started playing a game against an unaltered Fed side, built up an all conquering fleet, and went looking for the feds.... and found nothing but the intial base, and 2 construction ships doing nothing. Didnt think anything of it at first, just bumped the AI up a difficulty notch and got the same glitch again, until i destroyed the construction ships, and left the scene, returning later to find new constructors built and that the ai was building mining stations etc. I finished updating the Klingons and romulans, all without problems, and same with the Federation side, no issues with playing as them. But whenever I come to play AGAINST an AI controlled Federation it sits there doing nothing, and I cant figure out why, when the Klingon and Romulan fleets have had similar modifications (replaced texture files, ships over written (eg rbattle2 replaced by Norexan class), hero ships added) done to them, and still work normally, whereas the fed will just send the enterprise and defiant to harass me, and then sit and do nothing else. Any suggestions? A standard install of armada 2 didnt have that issue, even when modded to death, so whats changed with the fed ai in v1.1 to render them useless and impotent (much like the Fed itself more often than not....) s'pose in terms of continuity its accurate - no other ships in starfleet do anything other than the enterprise and the defiant :D




archerscott

Make it so!

50 XP

21st February 2005

0 Uploads

145 Posts

0 Threads

#2 11 years ago

Yes I get that. Some Mods make my AI go superwild and boxer type and it blows me up! Or the base and constructors just sit there doing nothing. Even if I blow up the construction ships - the starbase will make replacements and then stop again. Not sure why, but it's the added things that change it. What I usually do for every change, I restore an original file and I only MOD one side at a time or just several ships.




Knight-2000

Dread thinks I'm a special person

50 XP

19th March 2006

0 Uploads

338 Posts

0 Threads

#3 11 years ago

thats the thing, at that point, I hadn't changed anything with the Fed side at all, there was no reason for it to suddenly stop working.

I dont see where the problem lies when the other races have had similar changes done to them and still work :s




Knight-2000

Dread thinks I'm a special person

50 XP

19th March 2006

0 Uploads

338 Posts

0 Threads

#4 11 years ago

which files it is you think probably need replacing with the originals?




Knight-2000

Dread thinks I'm a special person

50 XP

19th March 2006

0 Uploads

338 Posts

0 Threads

#5 11 years ago

ok, replacing the "fed.odf" file with the original makes it work. Though it stops again anytime i try to add the enterprise/defiant to the starting units. which is annoying, since Martok's Negh'Var works fine in the Klingon starting units.....




Guest

I didn't make it!

0 XP

 
#6 11 years ago

I believe if you press Ctrl-Shift-A or something of that sort, it brings up an AI Dialog, so you know what the AI is trying to do. That may help you find why the AI is stuck. It seems to be a build que error, that it is being told to build something it can't or in the wrong order.

EDIT: Regarding the reason why it works when you replace the race ODF with the original, it may be due to something like this.

Say you had a new construction ship, that overwrote fconst.odf (and you made a new basic construction ship, say caleld fconstb.odf). This new const ship for example might not be able to build anything except some massive shipyard or something. Now say you added this to the race.odf. If the AI only started with these ships, and the AI was told to build these construction ships and then a mining station, it wouldn't be able to build a mining station but if its construction ships were destroyed it could rebuild them from the starbase.

As you have said you have overwritten some default ships, so perhaps you've done something like this. Trust me, tis easy to do even when adding new ships. That new (compared to Armada 1) function of pressing Ctrl-Shift-A (it might not be that, but its something similar, and if memory serves you might need to press Ctrl-A to make it cycle between what AI player it is reporting, and also what degree of information you get) has really saved me alot of hassle, especially combined with the AI settings on Instant Action. Ramp that up to full and my AI can kick out Battleships in 30 seconds, and thats with considerably longer tech trees and build times and a larger number of ship classes compared to stock A2. With these two functions I can see if an AI build list works in seconds, rather than hours.




Knight-2000

Dread thinks I'm a special person

50 XP

19th March 2006

0 Uploads

338 Posts

0 Threads

#7 11 years ago

Thanks for the advice. I'll give that a go.

I must also admit that after the AI was restored (via using the original file) it completely destroyed me lol, on customised options (set to medium difficulty but with AI build time and resource cost set lower to make it harder).

just sent wave after wave of the replacement sovereign i used (i think its admirals) and just completely annilihated me. even my fleet of Negh'Var's couldnt stand up to them! still.... gotta love a challenge :D




archerscott

Make it so!

50 XP

21st February 2005

0 Uploads

145 Posts

0 Threads

#8 11 years ago

Yes, replacing original files works. :nodding: What I meant before was that if I add a modification to the Akira Class then I'll replace the Sabre Class to its original specs. My computer only lets me have up to 10 changes at a time or it won't play and I have to re-install. :eek: That's how I got into the habit of replacing files. However one good thing is that I have a different game every week! Its been great value since I got it a couple of years ago. :)