freighter does not appear -1 reply

Please wait...

AssimilateThis

I See No Ships

50 XP

19th October 2009

0 Uploads

80 Posts

0 Threads

#1 8 years ago

Hi there fellow modders and alike! have a strange prob wiv my moddin rite now. downloaded the talaxian ship pack and it lacks the sod file (i think) for the freighter. so im converting the construction ship to be the freighter. the prob is after adding to tech.tt, adding the bb and wf to the global file, renaming odf/sod (to xfreight.odf and xfreight.sod), followed by renaming BB/WF (gbxfreight and delwireframe1) texture files, then added to the station to build it. but when i play it, it does not appear (no BB or empty gap to where it shud be), (just in sequence xconst, xcargo and xsrepair). on the map editer i added the delta race and list catogories, and in the ncomba file its item no2, but when i use it number 2 isnt there. so i added it as a starting unit and its there wiv its rite SOD and Textures????? any takers on the prob at hand (that i seem to be missing/forgetting) ps had prob before wiv dominion freighter, but renamed it dfreight1 and it worked, but no such luck wiv this 1...:confused:




Harcourt Fenton Mudd

----------------------

50 XP

7th October 2010

0 Uploads

112 Posts

0 Threads

#2 8 years ago

1: Spellcheck. Use it, even if just on your posts. 'wiv' is not a word, it is gibberish

2: Details. You THINK ? What .sod does the .odf from the mod call on ? Have you checked to see if it is there ? Have you checked the comments section for the mod to see if this has been mentioned before ?

Also, were are you trying to build it from ? Did you do the .tt file properly ?

3: Did you add it to tech1.tt ? There are differnt tech files for differnt play modes, is your play mode matching the tech tree you added it to ? If it actualy works when you make it starting, it sounds like you actualy didnt add it to the propper tech tree.




Avon

Ageing Rapidly

50 XP

27th October 2006

0 Uploads

483 Posts

0 Threads

#3 8 years ago

Talaxians? Lol. Didn't think many people used them. Well i seem to remember including the freighter in the pack (although by accident). I'll check later when i get home from work. But mudd is right, sounds like a techtree problem.




Harcourt Fenton Mudd

----------------------

50 XP

7th October 2010

0 Uploads

112 Posts

0 Threads

#4 8 years ago

Also, can someone link me to this ? Sounds like it'd be fun to give a whirl, if nothing else, to balance it so an intrepid can not just die in mere seconds against some of the ships.

Something tells me that when megadroids mission scripting gets finished someones gona be making a Voyager RPG mod with this eventualy I bet.

Assimilate, in general if you get a crash randomly, a .odf is corrupted. If you get a memory overflow error, it means you missed a " in a .odf (I just tracked one down last week that had eluded me since early this year for a personal mod........ those can be a REAL pain).

And if you just get a random crash, its usualy the techtree, often its something as simple as mistyping a .odf required for building or something really simple like that. To

The easiest way to test either .odf OR possible tech tree errors is to do one of two things

1- If you have all of the ships/stations from the mod in the editor, place one of every one of them and give it something to shoot.

If it crashes as soon as you place a ship, that ships bugged. If it crashes in combat, one of its weapons are bugged, and if using a mod remember that often moders will add multiple versions of a weapon based on the same ordnance file with the differnce being a slightly differnt refire rate, so as to have not all guns shoot at the same time past the inital salvo, if a single one of those is bugged somehow, it can also casue issues.

If the ship works until it shoots, a weapon is bugged. Rather than check the weapon .odf's (unless it has a single beam weapon and a single torpedo and nothing else, in which case thats easy to do fast) and even when that is the case, it is often easiest to just comment out (start the line with // ) the weapon, (make sure to renumber the following weapons of course) or replace it with one you know works (IE: a vanilla one) and see if it works. If removing/replacing a gun works, that gun is messed up and you should then check that weapons .odf's




Avon

Ageing Rapidly

50 XP

27th October 2006

0 Uploads

483 Posts

0 Threads

#5 8 years ago

Well, I just checked and the freighter sod was indeed included in the Talaxian pack.

Harcourt Fenton Mudd;5414381 Something tells me that when megadroids mission scripting gets finished someones gona be making a Voyager RPG mod with this eventualy I bet.

Well these Talaxians were from a Voyager total conversion I was making some time ago. The Talaxians were from my Voyager Alliance side. Come to think of it, I have a mining station and starbase for them somewhere. Anyway, I gave up on the mod some time ago, and released a few bits and pieces. The only other bits still to come from that old mod, is my Hirogen full race (which will be released fairly soon)




AssimilateThis

I See No Ships

50 XP

19th October 2009

0 Uploads

80 Posts

0 Threads

#6 8 years ago

well Avon, Talaxians are fools like me, here is an apology on the error i made. All the ships are there, the only thing missing was the sprite entries for tfreight for both BB and WF. Im going to have a break from this i think (say a year LOL). I like the talaxian mod you done (they look like modern fighters with those wings) and the starbase and mining station sound cool too. TY for reply.

and Harcourt Fenton Mudd, u (oops 'you') were right too, i never moved the edited tech file into the game (so error again i my behalf). as for spellcheck, 'wiv' is old school texting for mobiles (old habit), can i assume your a youngster. ps 'differnce' and 'differnt' need to be checked too LOL. anyway cheers mate for the replies, and sincere apologies for creating a pointless thread.