I forgot how to do this stuff :-( -1 reply

Please wait...

B4LE

I don't spend enough time here

50 XP

22nd August 2003

0 Uploads

24 Posts

0 Threads

#1 11 years ago

It's been three or four years since I've played. When I started playing again, I remembered why: The game kept crashing on me.

I managed to fix that for the most part. It's probably a naming or an hp issue.

My new problem is this: 3 of my ships have the white bug icon. One of my stations has the white bug icon and does not collect resources. My Breen station does not appear to shoot.

Can anyone put me in the right direction?




kel333

IWL: Klingon Defense Force

50 XP

10th June 2005

0 Uploads

728 Posts

0 Threads

#2 11 years ago

The bug box means the game doesn't recognize the sod the odf is requesting. Take note of which ships/stations are "bugged" and look in the odf and sod folders to see if they're there. If not, you'll need to either get the missing sod(s), or substitute with one you do have. You can do this with the: baseName = "sodname" command.




B4LE

I don't spend enough time here

50 XP

22nd August 2003

0 Uploads

24 Posts

0 Threads

#3 11 years ago

I figured out how to make hot keys again which is helping my game a lot.

I looked at the ODF that is the Borg orbital and it doesn't appear to have any SOD associated with it's file name. I then looked at the Federation orbital and there was no SOD associated with it either, but it still works and gets built like normal.

I think I am missing something in the explanation. :confused:




B4LE

I don't spend enough time here

50 XP

22nd August 2003

0 Uploads

24 Posts

0 Threads

#4 11 years ago

It means a lot that I can play this game again.




Guest

I didn't make it!

0 XP

 
#5 11 years ago

The stock stations have their ODFs named the same as their SODs. Sometimes this works for custom odfs (as long as the two file names match, but seems a little hit and miss) but I always use that line kel333 posted to ensure they always work.




kel333

IWL: Klingon Defense Force

50 XP

10th June 2005

0 Uploads

728 Posts

0 Threads

#6 11 years ago

Oh, yeah, Squire's right. I should've mentioned the sod and odf names are supposed to match. Like so: The Fed battleship is named like this: fbattle- which makes it's sod and odf files look like this: fbattle.sod and fbattle.odf. You can see that most of the files are pretty self-explanatory. Like cdestroy is the Cardassian destroyer. Normally, the sod will match but, as Squire says, including the command in the odf ensures the game will use the sod you want. Also, I realized I forgot to help with the other issues you mentioned. For the mining station not mining, borbital? I guess is might not have the right stuff in the odf. There should be an #include "orbital.odf" command in it. Also, it might be missing it's weapon. Look for something like this: // Mining Beam weapon1 = "gOrbitalBeam" weaponHardpoints1 = "hp05" about half way down the odf. Then, make sure the weapon is in the weapons folder. It should be in with the special_weapons. Then make sure it's ordinance file is there. And any other files the weapon #include(s). I'd look in the Breen station.odf for the same problem. A missing weapon or #include command. Ciao




B4LE

I don't spend enough time here

50 XP

22nd August 2003

0 Uploads

24 Posts

0 Threads

#7 11 years ago

Maybe the Borg does not use an orbital? I changed the name of the ODF and to borbital.odf and then played the game again...resource colllectors orbited the planet and dropped off the metal, just like it was picking up dilitium.

OK, now the other stuff. The three bugged out ships are JemHadar Bomber Ship (dcruise4.odf), the Dominion Private Yacht (dcruise5.odf), and the DOminion Private Missle (dmissle.odf). I have the odfs for them but not the SODs

My other problem is that I replaced the regular Dominion base with the Advanced Dominion Super Base, but the Super base doesn't build anything. Even though I put in a build menu into the ODF, I still get no build buttons.

Any ideas?




kel333

IWL: Klingon Defense Force

50 XP

10th June 2005

0 Uploads

728 Posts

0 Threads

#8 11 years ago
B4LE;4003808Maybe the Borg does not use an orbital? I changed the name of the ODF and to borbital.odf and then played the game again...resource colllectors orbited the planet and dropped off the metal, just like it was picking up dilitium. [/quote] Do you mean the stock Borg resource collectors work, then you tried to add an orbital station by changing the name of the mining station?
B4LE;4003808OK, now the other stuff. The three bugged out ships are JemHadar Bomber Ship (dcruise4.odf), the Dominion Private Yacht (dcruise5.odf), and the DOminion Private Missle (dmissle.odf). I have the odfs for them but not the SODs
If the sods are not in the sod folder (or anywhere else) you'll have to: substitute with something else by renaming a sod of your choosing to the one you want (which should work, as long as there are no hardpoint errors), or get the sods by searching online (A2Files has all of those as separate downloads), or remove them from your build lists, tech trees, and AI files. [quote=B4LE;4003808]My other problem is that I replaced the regular Dominion base with the Advanced Dominion Super Base, but the Super base doesn't build anything. Even though I put in a build menu into the ODF, I still get no build buttons. Any ideas?

Hmm, I thought on this a while, then it occurred to me, how is it named? If you replaced the standard base without naming it the same, then the tech tree won't identify it, and anything dependant on it wont be buildable. If this is the problem, rename all instances (odf, sod, etc.) to the original base name as it is in the tech files. San Soui?